-   Fedora (
-   -   yum --installroot install cannot find /proc directory in Fedora 17 (

alan.vitor 04-03-2013 04:41 PM

yum --installroot install cannot find /proc directory in Fedora 17
I'm creating chroots of Red Hat-based distributions inside my RHEL (host OS) and using them to build packages for different distributions. The process is described here: For Fedora, I setup a basic environment with rpm -i --root=<myroot> --nodeps and then use yum --installroot=<myroot> --disablerepo="host_repos" install <package_name> to install packages needed to build packages.

This process works fine for Fedora 15 and 16, but the yum install crashes on Fedora 17/18 at the yum install with the error: [Errno 2] No such file or directory: '/proc/317/cmdline'. The /proc/ directory does not exist inside <myroot> directory at this point.

Why this process does not work in Fedora 17+? Any workarounds?

edit: I've read I possibly would need to bind chroot's /proc and /dev to the one in host os. I've tried that and it still does not work.

Thanks in advance.

greatbear 04-09-2013 01:40 PM

I have done only a one experiment with creating a chroot environment and cannot help much but I came across a utility called Mach which purports to automate the chroot install process. I have not personally tried it. Its used for testing package builds.

Have you looked at the Mach utility?

Best of luck!

(I have Fedora 18 on my Dell Inspiron N411z laptop which runs a i3 Intel based configuration. Runs like a champion.)

All times are GMT -5. The time now is 04:56 PM.