LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   Yum cant seem to connect to any repo (https://www.linuxquestions.org/questions/fedora-35/yum-cant-seem-to-connect-to-any-repo-402629/)

Zut50 01-12-2006 05:03 PM

Yum cant seem to connect to any repo
 
yum seems to have stopped working, and I cant seem to find any hints at a solution on the web. Im running FC4 with the 2.6.14 kernel if that makes a difference.

Whatever repo I try it either says it cant read the repomd.xml or that it has a bad baseurl. I've tried disabling one repo at a time, but I get one of two messages...

Code:

[root@fifi ~]# yum install libxml2
Setting up Install Process
Setting up repositories
<< very long pause >>
Cannot open/read repomd.xml file for repository: at-stable
failure: repodata/repomd.xml from at-stable: [Errno 256] No more mirrors to try.

..or...

Code:

[root@fifi ~]# yum --disablerepo=atrpms --disablerepo=at-stable --disablerepo=freshrpms --disablerepo=extras install libxml2
Setting up Install Process
Setting up repositories
<< very long pause >>
Cannot find a valid baseurl for repo: updates-released

(Im trying libxml2 as its in the list of dependencies for a tool I have to install from source. Being a bit of a noob I woudn't know if this was already in FC4... I'm just going through the list!)

When I tried to install a public key for freshrpms (I had done this before, but I tried it again just as a test) there was an even longer pause and then it segfaulted!

It was working perfectly a few days ago, and I cant think of anything I have changed that would make it stop working. The last time I used yum I was using a different modem router on the network, but I cant see how that would make a difference.

Its really infuriating when you're trying to deal with one massive headache and then something else just stops working suddenly like this!! :(

Does anyone know what might be wrong here?

Thanks :)

Ahmed 01-12-2006 05:07 PM

This yum setup works well for me. Try it out

-A

Gethyn 01-13-2006 11:53 AM

Is the internet otherwise working normally in Linux for you? Usually when I have problems of this sort, it's because the DNS settings aren't working properly. If you have just changed to a different router, this could be the cause.

linmix 01-13-2006 04:43 PM

either any of the above, or... your yum.conf file is set to the wrong mirrors and with a too short waiting and retry time. Check out Stanton-Finley's explanation as per the above link and also have a look at www.fedorfaq.org which has a yum.conf file ready to download and some more suggestions to get it all to work properly.

Zut50 01-15-2006 10:30 AM

Thanks for the replies guys.

I think its some kind of networking issue. If I try to ping atrpms.net the IP address is resolved, but no packets are received. Also firefox does not work at all.

I know my router and atrpms.net are both working though, as I can visit that site from other machines on the same network.

garrik 02-25-2006 11:22 AM

Hi all,
I think I have the same problem Zut50 has had.
I followed exactly all the steps suggested by Stanton Finley's explanation, however when I tried...

Code:

[root@Alba ~]# yum update
Setting up Update Process
Setting up repositories
Cannot open/read repomd.xml file for repository: core
failure: repodata/repomd.xml from core: [Errno 256] No more mirrors to try.

I've got a DSL-504T Linksys modem-router and I use NAT to connect to the Internet. I think there could be a networking related problem, but I don't know how yum works (has it to create a new connection to my pc? May this be the cause of the problem?).
Most of all I am a newbie! ;)
Can someone help?

tmick 02-25-2006 03:01 PM

Hi Garrik and Zut50,
Try running yum clean all from the CLI(command Line Interface aka a terminal) and restarting network services. Then run yum and try using yum install yumex. that is the easiest way I have found around the problem. For some reason core for keeps losing the connection and network services needs to restarted, you can also use service network restart to restart your network connection.

garrik 02-27-2006 04:20 PM

Thank you for help tmick, but it doesn't seem to work. Also doing this way I have the same error as before...

tmick 02-27-2006 11:46 PM

Ok, what do have for drivers...meaning is it NVidia based? I had that problem and installing the driver from the OEM and installing the Kernel Module for Nvidia fixed it. BTW I goofed on the commands the proper order should have been:
1) yum clean all
2) yum update yum
3) install these repos
rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY*
rpm --import http://rpm.livna.org/RPM-LIVNA-GPG-KEY
rpm --import http://freshrpms.net/RPM-GPG-KEY-freshrpms
rpm --import http://dag.wieers.com/packages/RPM-GPG-KEY.dag.txt
rpm --import http://atrpms.net/RPM-GPG-KEY.atrpms
rpm --import http://newrpms.sunsite.dk/gpg-pubkey-newrpms.txt
rpm --import http://apt.sw.be/dries/RPM-GPG-KEY.dries.txt
rpm --import http://www.jpackage.org/jpackage.asc
rpm --import http://kde-redhat.sourceforge.net/gp...382fa-3e1ab2ca

4) Enable these repos with yum --enablerepo=<repo name>
5) run yum install yumex

If the drivers are not available through yum the Google either Fedora NameOfHardware or Linux NameOfHardware and follow those proceedures to install the correct drivers.
If all else fails pose the question to http://fedoraforum.org/ it's the core support web site. It sounds like to me your NIC card is losing connectivity. I think it could be because the proper drivers for it are not installed. You might try restarting Network services by either using the GUI or typing service network restart at the CLI as su -

joesnow 02-28-2006 05:20 AM

I've been having the same issue lately. Only lately o.O

garrik 03-02-2006 03:31 PM

Quote:

Originally Posted by tmick
Ok, what do have for drivers...meaning is it NVidia based?

I have a ATI radeon 9600, so I don't think there are NVidia drivers on my pc.

Also the new command sequence doesn't work. :scratch:
I'm going to pose the question to the Fedora forum.
Thank you anyway.

tmick 03-02-2006 09:44 PM

http://www.fedorafaq.org/
Has how to install Radion Drivers might try that.

garrik 03-30-2006 02:44 PM

Ok, I've found a solution: Fedora Core 5.
Now yum 2.6.0 works well.
Thank you.
byez


All times are GMT -5. The time now is 07:22 AM.