LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   Yet another Nvidia Driver Question (https://www.linuxquestions.org/questions/fedora-35/yet-another-nvidia-driver-question-158576/)

THX75 03-16-2004 04:50 PM

Yet another Nvidia Driver Question
 
I'm using Fedora Core 1 with the updated kernel (2.4.22-1.2174.nptl). I've tried all day to get the Nvidia drivers to load on my system, but I keep getting the "Black Screen" when X starts to load. I have the MSI G3Ti200 Pro2 TD card.

Anyways, I've tried using the rpm drivers from livna.org and I've tried 2 different versions of drivers from Nvidia (4496 & 5336). I followed their directions and made sure that my XF86Config was configured right. I've tried messing around with the NvAGP option. Nothings worked so far :(

I've pasted the failed section of my XFree86.log below. It mentions something in the log about the kernal module failed to initialize. Does this mean that the driver and the kernel module aren't "talking to each other"?

Has anyone had any success in getting past this problem in FC1?

TIA

********************************************************************
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.3.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.6
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xD8000000
(--) NVIDIA(0): MMIO registers at 0xDE000000
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!
(EE) NVIDIA(0): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "vgahw"
(II) Unloading /usr/X11R6/lib/modules/libvgahw.a
(EE) Screen(s) found, but none have a usable configuration.
********************************************************************

Andrew Benton 03-16-2004 05:54 PM

Does it work if you type in
modprobe nvidia
first?
If so, put the line
alias char-major-195 nvidia
in /etc/modules.conf (or /etc/modprobe.conf for people using a 2.6 kernel)

THX75 03-19-2004 10:38 AM

Sorry it took so long to get back on this.

It looks like the Nvidia installation already put your line of code in my modules.conf. Any other ideas?

This is a new installation of FC1, so a reinstall wouldn't kill me as I haven't done much customization yet. I've read other posts on this board where a reinstall helped. We'll see....

THX75 03-20-2004 12:13 PM

Nvidia Driver Working!!!
 
Well... I was bored so I reinstalled FC1 this morning thinking it would help with my Nvidia problem. I used Yum to install the latest kernel and livna.org Nvidia kernel module. When I first booted up using the Nvidia driver, I got the same darn blank screen that I've been getting. I was fairly upset and turned to another computer in my office to search some more on the problem. After about 3 minutes, Xwindows started up to my amazement. It then got to the end of the Fedora GUI startup screen and went blank again. It stayed blank again for another 2 or 3 minutes, but eventually loaded the login screen.

I did an lsmod and the Nvidia module is loaded. My only test is Tux Racer and it seems to run pretty good. Nice thing is that my monitor's horizontal position is now correct as it was always off-center and to the right.

So... my advice to those who are experiencing the blank screen is to give it time to load.

Does anyone have any advice on making the Nvidia drivers load faster?

Andrew Benton 03-20-2004 12:42 PM

Edit /etc/X11/XF86Config and make sure it has the correct vertical and horizontal refresh rates for your monitor.

THX75 03-20-2004 01:59 PM

Hi Andrew,

I cracked open my monitor's manual and my horizontal sync was indeed off by 6, even though I have the correct monitor in config. It didn't help with the slowness problem though. I think there's some AGP options I can put into the config that I might mess around with.

I can live with this until I figure out a solution.

Thanks,

THX

THX75 03-21-2004 05:08 PM

Problem Solved!
 
I found a post in another forum were a guy was having the same problem I was having, but in RH9. See Post

All I did was add the following to my device section of XF86Config.

Option "IgnoreDisplayDevices" "DFP, TV"

Fedora now loads Nvidia driver and doesn't hang after the Fedora startup GUI. Hope this might help someone.

haku 04-27-2004 06:46 PM

I hate to post in an old thread, but I figure I might get some help if I do, so...

I'm having the same problem as everyone else.
My mandrake 10.0 install doesn't display anything---just a blank screen.
I'm an uber-newbie in terms of linux, so I'd really appreciate one of you walking me through a fix for this problem.


Thanks,

J


All times are GMT -5. The time now is 09:28 AM.