LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   Xorg-X11-server quit unexpectedly in Fedora 29 (https://www.linuxquestions.org/questions/fedora-35/xorg-x11-server-quit-unexpectedly-in-fedora-29-a-4175648249/)

SamuelLittle 02-13-2019 02:16 PM

Xorg-X11-server quit unexpectedly in Fedora 29
 
Hello, everyone! Iím a completely new user, so I donít know much about Fedora Linux. Iím using Fedora 29. And I need help in solving one issue. It constantly happens so that after using VirtualMachine for a while desktop stops responding and the system reboots by itself. After logging in I receive a message that xorg-x11-server quit unexpectedly. I tried looking for a solution on the Internet. I found this post: https://www.linuxquestions.org/quest...ly-4175622783/
so I tried this solution, with the latest version of gjs (1.54 fo fedora 29) but that didnít work for me. I also tried reinstalling xorg-x11-server-Xwayland from official sources, but that didnít help either. Hope you can help me.

Brains 02-13-2019 10:03 PM

Quote:

after using VirtualMachine for a while
Although the quote above is lacking information, I'm guessing you are running a virtual machine full screen. If so, it's possible power management sees the desktop as inactive after the set amount of time lapsed and tried turning it off, perhaps turning off screen energy savings in power management or extending the amount of time before turning it off may alleviate this behaviour.

SamuelLittle 02-14-2019 07:01 AM

Actually, I am using virtual machine full screen (it is VirtualBox 6.0 with guest addition), but I have set the amount of time before turning off to never in the settings. I also will be glad to tell you any additional information.

6th_sense 04-08-2019 11:41 AM

Hi SamuelLittle,

It is possible that virtual box is too demanding for your machine - what are your machine specs? Processor, RAM...

I faced a similar situation - where the machine would freeze, but I had the memory monitor and CPU monitor running and they would hit the limits given to the machine and I could subsequently not start the virtual machine any more.

- 6th -

SamuelLittle 04-09-2019 11:43 AM

Thanks, 6th_sense
Actually, that was the problem. It turned out that the particular virtual machine was too demanding. So I tried to change its system settings. And it worked when I decrease the amount of CPU threads from 4 to 2 and the amount of RAM from 8 gigs to 2. So I don’t have this issue anymore.


All times are GMT -5. The time now is 07:05 AM.