-   Fedora (
-   -   X11 Forwarding with Gnome Desktop in Fedora 8, Issues (

captainxark 07-18-2008 07:12 PM

X11 Forwarding with Gnome Desktop in Fedora 8, Issues
I've got two systems running Fedora 8 with a Gnome desktop. The client for the x11 forwarding is off an xfce spin and the host is off the live cd.

When I connect with ssh and run 'gnome-session &', it shoots out a ton of errors for various gnome desktop features like Tomboy. Panels appear over the local panels and the desktop background switches.

A few questions about how to improve this. A friend of mine does X11 forwarding with KDE and gets a really nice remote desktop and I'd like to make it more like that, maybe learn more about gnome in the process.

What is causing all the errors with the various gnome features?

What logs will help me troubleshoot this?

Is it more likely that the remote system doesn't have something installed or that the host isn't serving a resource?

Why does it change the background on all four desktops, plus panels on all four desktops?

Is there anyway to just make desktop #x turn into the remote desktop? This would be sweet.

theNbomr 07-20-2008 09:59 AM

What do you mean by 'The client for the x11 forwarding'?
Are you trying to run a desktop using an X server that already has a desktop displayed from the local host?
I'm not sure what connection you are trying to address between the desktop manager and X11 forwarding. Port forwarding is a function typically provided a firewall, and X tunnelling is typically provided by an SSH client. What role that the desktop is providing has anything to do with X, other than the X server's function as a $DISPLAY?
--- rod.

johnson_steve 07-20-2008 10:11 AM

why not use vnc? it's designed for that and it would be faster.

captainxark 07-21-2008 03:05 PM

Thanks for the responses, I'm sorry if I was unclear.

Steve, I can use VNC and I have it up and running. This is something a friend of mine uses and I'd like to be able to do it as well, and learn some stuff.

Nbomr, I should have said 'client machine' instead of client. The laptop is connecting to the server with only a terminal to get the window. I intend to use ssh tunneling once I get gnome running normally.

And yes, the desktop is already displayed on the remote host. These are both computers sitting in my cubicle with gnome gui, on LAN behind firewall.

Not sure what you mean by:

'What role that the desktop is providing has anything to do with X, other than the X server's function as a $DISPLAY?'

I think you're asking why I am doing this...I'm expected at my job to back up the system administrator and begin taking over administration of some less important boxes in the rack running windoze server 2003 in vmware. This is my practice setup. Goal is to be able to do this from a fedora laptop at my fingertips. Ideally, one of my virtual desktops would be the desktop from a different computer.

As of now, as soon as x11 forwards to my terminal, it takes over all desktops and places panels over the top of my other panels, making only the remote desktop useable.

More specifically on the errors,

As soon as I run 'gnome-session &' I get a:

'Hostname lookup failure on localhost'


'X11 connection rejected because of wrong authentication'


'gnome-settings-daemon has crashed' from Bug Buddy. Also a system message saying 'some things, such as themes, sounds or background settings may not work correctly.'

The terminal that started the connection and ran the command gets a bunch of messages like:

** (gnome-panel-2474): WARNING ** panel-applet-frame.c:1293: failed to load applet GNOME_ClockApplet; Failed to resolve or extend '!prefs_key=/apps/panel/applets/clock/prefs;.....

Tomboy, systemtrayapplet, mixerapplet, workspaceswitcherapplet, trashapplet, windowlistapplet, showdesktopapplet.

These are all desktop items on the remote machine that maybe i shouldn't expect or need to run on the local machine.


In the page of errors, it also mentioned something about the --replace option, which isn't in the gnome-session man pages. Although there I did learn that I could specify a different session maybe I'm just asking what should I put in a gnome session file to make this work better?

theNbomr 07-21-2008 10:51 PM

How about running a second X server on the remote host, and use that to serve your remote desktop. In any Redhat-ish setup I've used, you can switch to different servers with Ctrl-F7..Ctrl-F10. The second server would be :1.0 and use port 6001.
AFAIK, most sysadmins tend to use text-mode tools, or just run individual X applications, in part to avoid the sorts of problems you are trying to solve.
--- rod.

captainxark 07-23-2008 06:12 PM

point taken
Thanks for the second x window idea, going to try this out.

And I wouldn't be really doing this if I weren't administering 2003 servers which don't have such great cli controllability.

Thanks again,


All times are GMT -5. The time now is 09:33 AM.