-   Fedora (
-   -   WOW and Intel HD Problem (

scorpioofthewoods 11-04-2013 11:01 AM

WOW and Intel HD Problem
I have searched and searched and I can't find anyone else with this problem posted anywhere. Maybe it is just my own special problem.

I have Intel HD graphics Ivybridge Intel Core i7-3610QM CPU @ 2.30GHz 8 on my laptop. Having used Ubuntu with Wine 1.6 I was able to install and run World of Warcraft just fine. I had no problems at all.

Now I am running Fedora 19 which has Wine 1.7. WOW installs just fine. I can start the game, log in, create and select characters and log into the servers just fine. Everything looks and runs fine with default settings. Everything that is until I see another player on the screen. At this point the other player is black. They look like a black shadow running around. Also when another player is on my screen everything in the environment turns to a rainbow texture and starts flashing and things slow down. Once they are off my screen everything is just fine again.

If I try to change the settings to use opengl everything is fine until I try to log in with a character. I can get into the server and see my character standing there. Then it crashes and throws an error. I have searched for this error but all I come up with are old posts that seem to have nothing to do with my situation.

I have searched through the wine folder to look for some kind of error log but I don't see anything, though I don't really know where to look exactly either.

I have tried reinstalling WOW but this didn't help.

Everything is fine as long as I have nothing to do with other players, which defeats the point of such games.

Does anyone have any ideas?

angryfirelord 11-05-2013 10:02 AM

Have you tried the suggestions in this test report?

scorpioofthewoods 11-06-2013 10:58 AM


Originally Posted by angryfirelord (Post 5058755)
Have you tried the suggestions in this test report?

Thank you. I went back and checked the steps but that did not help.

I have solved the issue while setting up another game. Apparently, for some reason, player characters have something to do with S3TC. When enabling this for the other game my issue with WOW was resolved and everything runs great now.

In case anyone else has this issue I will share what fixed this for me.

Have RPM Fusion repo enabled.

Install the libs for S3TC textures. I am running 64 bit so I installed both 64 and 32. Also install driconf.

sudo yum install libtxc_dxtn libtxc_dxtn.i686 driconf

Open driconf and enable S3TC.

Everything should be running fine on games that use S3TC now.

All times are GMT -5. The time now is 01:27 PM.