-   Fedora (
-   -   Wireless vs wired connection on same laptop (

rps63ifid 01-28-2005 07:01 AM

Wireless vs wired connection on same laptop
I have a Dell D600m laptop dual-booting WinXP and FC3. The box has a built in NIC and a Centrino-based wireless connection. I use the box at work with the wired connection active, and at home (under WinXP, to this point) with the wireless connection to talk to my home network. I recently got the wireless connection configured and ALMOST working under FC3 using the IPW2200 packages. I don't think I will typically need both connections active at the same time.

Like I said, "almost"...

Last night, when I fired up FC3 here at home and tried to connect to my WAN for the first time, I succeeded in connecting (I had a strong signal, etc.) and my WAP showed a connection from the appropriate MAC address. I had an IP assigned by the WAP (using DHCP) there. Problem was I could not seem to get to the outside world via my connection. It seems like when I start up a Web browser, it doesn't know to use eth1 (the wireless connection) and/or it is still trying to use the DNS settings, etc., that are configured for use when I am connected to my work LAN via eth0 (the wired NIC).

I am obviously missing something fairly simple in getting the network configuration set up to fully use the wireless connection. Can someone point me toward the needed steps to be able to easily switch between the wired and wireless connections, depending on where I am (wired at work, wireless at home and possibly when travelling)?

Thanks in advance!

jtshaw 01-28-2005 08:14 AM

Your route table needs to be updated. Most distributions would do this automatically if you load the wireless init script with the wired init scrip unloaded.

To check your route table run "route" on a command line. See what iface the gateway is using.

ben_build#2.1.0 01-28-2005 08:39 AM

just a simple question. Do you have ADSL at home?

If so you need a program to interface with the connection. I was having similar problems until I downloaded Roaring Penguin PPPoE and that gave me the opportunity to connect to the internet.

also check to see if your dns numbers are in /etc/resolv.conf

hieudt 01-29-2005 08:35 AM

Try this: /sbin/ip route add default dev eth1

It worked for me.

rps63ifid 01-29-2005 10:21 AM

Thanks! I will give the "route" command a shot later this morning. It makes sense to me that this should be part of the solution. The remaining question (at least in my mind, until I get a chance to play with this) will be how DNS will work, given that on my eth0 connection I have two DNS entries specified that correspond to work servers. On my other systems with wireless connections at home, the DNS is dynamically handled...

I will give it a shot and see what happens, and then post a follow-up.

Thanks for the help!

jlawren7 01-31-2005 08:32 AM

just a hint if all other stuff doesn't work
i have a centrino based notebook as well XP & FC3 dual booted the networking is better in FC3 than XP. I use NetworkManager. it auto detects which network device is the best and tries to connect.

see if this helps you out....

Updated link

rps63ifid 02-02-2005 06:45 AM


Thanks for the tip. I will give this a shot this evening. I tried the "ip route" command above and it failed. I don't have my laptop with me at the moment, so I don't have the specific error message in front of me, but it seemed like it was failing to get the wireless connection established as the default connection.

rps63ifid 02-02-2005 09:38 PM


It works! I am wireless even as I write this...

I had the two packages already installed that were mentioned in the article at the URL you supplied, so it was just a matter of turning on the NetworkManager service, and then starting the NetworkManagerInfo thingy (what do you call those, anyway? an applet?). The first time that I booted after setting the NetworkManager to start, I couldn't get it to connect. It saw my home WAN, and prompted me for the WEP key, but I couldn't get it to connect. I'm not sure what the difference is, but I rebooted and this time it connected.

I haven't played much with it, but at least I know it worked one time!

Thanks for your help!

All times are GMT -5. The time now is 02:43 PM.