-   Fedora (
-   -   wireless networks not detected (

thetenor 08-17-2011 11:51 AM

wireless networks not detected
The power went out. Rebooted cable modem and wireless router. Wireless networking is enabled on laptop. Wireless networks not detected. The only switch on the laptop that appears to be a wireless switch is illuminated and will not turn off when pressed. Network dialog says wireless is on and there is a hardware address. However, the dialog says wireless is not available. This has never happened before.

frankbell 08-17-2011 07:44 PM

I would test that the wireless router was broadcasting with another computer or wireless device and verify that it's settings were correct.

This may require jacking into the router with a cable, which would also be a good way to verify that the router was connecting to the internet.

Before focusing on the Fedora computer, it's a good idea to verify that the network is available.

thetenor 08-17-2011 07:56 PM

Network is working. I am able to connect wirelessly with another laptop to the router and Vonage is working. Before this incident, I could see other nearby networks. Can't now. I know for sure that wireless is "on" via the network manager dialog in Gnome 3. It says that wireless is on but unavailable and it lists a hardware address.

frankbell 08-17-2011 08:20 PM

I don't have a good feeling about your wireless card.

Does lspci detect it?

Please post the specs of your computer (laptop? desktop? type of wireless card?).

You might try booting to a Live CD and checking whether it can detect the wireless. If it can, that would narrow this to a software problem and indicate that the power failure tangled up some electrons.

thetenor 08-17-2011 08:50 PM

Frank, thanks for all this help. specs: HP laptop (forgot model and took off sticker), core 2 duo x 2, mobile intel gm45 express chipset 32 bit, 3g ram, 50g disk, lspci shows atheros AR928x wireless network adapter (pci express). I'll try booting to live disk and let you know tomorrow.


thetenor 08-18-2011 07:20 PM

Rebooted from live disk and still get same result, wireless is on but unavailable. I need to know how to install lshw from a file in Fedora 15.

frankbell 08-18-2011 08:27 PM

I'm not an expert in Yum, but I think "yum provides lshw" will tell you what package contains lshw.

pbone reports that is available in rpms. If worse comes to worse, you can grab one there:

thetenor 04-08-2012 07:57 AM

Apparently, the wireless card is bad because wireless connectivity is not available in both Windows Vista and a new installation of F16. Thanks for all the help.

All times are GMT -5. The time now is 11:33 PM.