-   Fedora (
-   -   wireless Keyboard not working to select boot options (Grub boot loader) (

psrini_vasan 03-18-2005 08:24 AM

wireless Keyboard not working to select boot options (Grub boot loader)
i have successfully installed fedora core 3 linux on my machine which is also having winxp. But i couldn't able to select the boot option with my keyboard. the boot loader automatically loads the default boot. i want to know is it necessary to buy a ps/2 keyboard or could i select option with wireless keyboard(any software to be installed??)

Ricky2004 03-18-2005 08:45 AM

is it a usb keyboard? maybe the BIOS doesn't have the minimal drivers to handle it. I have a PS/2 wireless keyboard and it works quite well (i.e., like a driverless normal keyboard).
Try using a USB>PS/2 adapter, or making the bootloader wait a few seconds more (to give the BIOS more time to interpret whatever the keyboard is doing). But I could be WAY wrong about this.
Can you access the BIOS with your wireless keyboard? Regular keyboards can, but a fancy one may have trouble without drivers. If you can't, then you won't be able to use the bootloader anyway... I hope this is making sense to you.

chipix 04-28-2006 09:12 AM

Same problem with Creative wireless keyboard.
I have no problems managing the BIOS using either keyboard or mouse (both wireless). However, I canot use it with GRUB.

Any suggestions?

nDray 01-03-2007 05:11 AM

You should browse for some wireless/usb keyboard activation option in your BIOS, so that it can try to recognize those devices right on start-up....

EDIT: Sorry, this was the result of a google search, didn't realise it was so old.......

ferperezd 06-14-2008 07:28 PM

Using your wireless keyboard on GRUB
I had the same problem, I was able to use my wireless keyboard to access BIOS setup utility but not on GRUB, so what I did was, on the BIOS setup utility, I enabled the option: USB Kerboard support and also USB mouse support. That fixed it, now the Microsoft Desktop receiver stays on always and you can use the keyboard on GRUB to select the OS you wanna boot with. Hope that helps you brother.

Be well,

ronlau9 06-15-2008 03:19 AM

The Bios should mention the keyboard during boot , if not the BIos do not support a USB KEyboard and mouse
Read the BIOS message during boot to see if the mouse and keyboard is there.

all the best

MarkvanderPol 11-19-2009 10:21 PM

Same problem here. Not much use on the 'net for answers.

Here is how to solve it.

Unplug all your other USB devices, except the USB keyboard

If you've already done that, open your case, and unplug the internal memory card reader.

Presto - USB keyboard works as standard legacy devices.

I have no idea why some of these internal memory card readers have this effect. I had the same trouble with a SanDisk external reader, but of course, that is easier to unplug.

It is only at boot time, and only if you select USB Legacy Support (or equivalent 'USB Keyboard Support', etc, in the BIOS). After the OS has booted, everything works fine.

NeilMacK123 12-16-2009 05:45 PM

Setting the usb legacy option to yes worked for me. Thanks..

All times are GMT -5. The time now is 05:32 AM.