-   Fedora (
-   -   Wireless--Device not ready Firmware Missing (

pgb205 01-29-2011 09:57 PM

Wireless--Device not ready Firmware Missing
lspci gives
Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)

lsmod gives
b43 163484 0
mac80211 229015 1 b43
cfg80211 134933 2 b43,mac80211
ssb 49369 1 b43
jmb38x_ms 11812 0
mmc_core 64193 3 b43,ssb,sdhci

ifconfig -a gives
wlan0 Link encap:Ethernet HWaddr 00:24:2C:AB:D3:9A
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Network Manager shows error message above. I've checked the physical wireless switch and it's set to on.

What else should I do to get my wireless card working?
I'm on fully updated Fedora 14.


I believe this is resolved.
For anyone who has similar issues I've followed procedure on
under Fedora section. Worked right away.

stress_junkie 01-30-2011 08:31 AM

Thank you for posting the answer.

mickeyboa 02-05-2011 10:11 AM

uninstall the b43-cutter.rpm and install kmod-wl.rpm

kingkoti 02-13-2011 02:13 PM

@PGB205: Thank a lot. I really appreciate it.
@Mickeyboa: I tried your method. But i was struck. This is what I got.


KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: Entering directory `/usr/src/kernels/'
/usr/src/kernels/ stack protector enabled but no compiler support
make[1]: gcc: Command not found
LD /home/nik/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/built-in.o
/bin/sh: ar: command not found
make[2]: *** [/home/nik/Downloads/hybrid-portsrc_x86_64-v5_100_82_38/built-in.o] Error 127
make[1]: *** [_module_/home/nik/Downloads/hybrid-portsrc_x86_64-v5_100_82_38] Error 2
make[1]: Leaving directory `/usr/src/kernels/'
make: *** [all] Error 2

I tried installing Kernel-devel. Even tried to install the linux-headers. I'm using fedora. In debian lenny the method what you've mentioned worked. I mean, I followed broadcom's instructions. In fedora 14, it's not. Have any idea why?

Thank you.

All times are GMT -5. The time now is 01:45 AM.