-   Fedora (
-   -   windoze shares suddenly not accessible (

maxreason 03-06-2008 07:23 AM

windoze shares suddenly not accessible
system 1 = fedora8 : computer name fedora8x32
system 2 = winxp64 : computer name win64

I have had these connected for a month on my LAN, and have been transferring files back and forth (from the fedora linux side) via a "windoze on win64" icon/link that somehow got created on my desktop (and within the nautilus file browser).

All of a sudden, for no reason I can guess, I cannot access the windows share.

The icon/link on my desktop still exists, the "windoze on win64" place still exists when I run the nautilus file browser program, but I nothing I do lets me see the windoze folder any more.

When I try to gain access to the win64 machine via "connect to server", it does show an entry for "windows network". When I double-click that entry, it does show another window containing "windows" (the workgroup name on win64). But when I double-click that "windows" entry, it displays another window that is busy, busy, busy - for a couple minutes - then gives up and says something like "the folder contents cannot be displayed - cannot display [all the] files on Windows Network: windows".

I tried disabling my windows firewall - but that changed nothing. I have not changed any settings on windoze lately, so it is very unlikely I did anything to screw this up.

Any ideas?

sonichedgehog 03-06-2008 07:43 AM

I have different distro but also run dual boot. I had no automatic windows folder shortcut, so used a longhand method of creating vfat partition (which gets a drive letter in doze) and fstab mounting it in Linux with full access to all users. I didn't choose to mount my main (ntfs) doze partition, as I only need shared access to a few files. I don't know how your problem started & know nothing about fedora, but hope this comment is of some help. -Phil

maxreason 03-10-2008 05:15 AM

what happened
Well, I did not resolve the problem as stated above, but here is some additional information that might help a linux/fedora guru understand the problem better.

I did some ping of 192.168.1.* to see what other addresses on my LAN/router were assigned to my other computers (both of which do not appear under the "windows" category the "browse" does find and show). The addresses are not always the same, presumably due to order the computers are turned on, or as some kind of firewall-confusion-technology.

Anyhoo, under "places" I selected "connect to server". This time, rather than enter various combinations of computer names and/or sharenames, I simply entered the IP addresses my pings found. Presto chango - a window pops up showing all the shared drives and directories. Even after this is successful, the browse does not work! You'd think it would, given the fact it just found the computer and shares, and let me drag/drop copy across. But --- nope. Maybe this makes sense to someone. Not to me.

sonichedgehog 03-11-2008 03:36 AM

I'm no guru!! If the network places come & go, that might be "leases" ie DHCP assigns ip addresses but reallocates them if they aren't used for a while- in my network I sometimes have to ping a computer via my router b4 it comes up on my browser. Windows network access on Debian can be handled by Samba (I can't say whether its the best way for everyone but its the only way I know & works 100% for me), this is an application available for repository download. Wonder whether that is an option for you?

btw I have a similar problem to what you describe on Vista, I have to go in on the ip addresses- but after that the icon pops up in the browser.

All times are GMT -5. The time now is 12:51 AM.