-   Fedora (
-   -   Warning: at kernel/exit.c:814 do exit() (Tainted: P ) <- nVidia video problem? (

Hitboxx 10-06-2007 03:19 AM

Warning: at kernel/exit.c:814 do exit() (Tainted: P ) <- nVidia video problem?
Dear All,

A sad day for me, my Fedora is busted :( (God let me be so wrong)

Here's the situation, my nVidia graphics card mal-functioned and I sent it for a replacement since it was still under warranty. During this period, I disabled the nVidia driver using chkconfig and used the onboard Intel video and all was fine. Now I got my nVidia card back, changed the video config in BIOS from onboard to external PCIe, plugged in the card, and went on to boot Fedora. But, it came to a halt on this screen.

I tried in single user mode but the result is the same. I know probably I have to re-enable the nVidia driver using chkconfig again, but how do I get into the system? And isn't single user mode supposed to run in a very basic mode without any drivers being loaded? Or is the problem a totally different one?

It will be hard on me if I have to re-install Fedora, oh God, so much stuff in there, so many customizations, honestly I just can't do it again, don't have the time now, am in a job and so forth...

Posting this from Windows from the same system and things are fine here.

Appreciate your help

EDIT: Hey reading the bottom message in that pic "rm -f /var/gdm...", I now remember that the last shutdown was improper, had a power cut and I was changing the GTK theme. Something fishy here?

osor 10-06-2007 11:10 AM


Originally Posted by shrikant.odugoudar (Post 2915057)
But, it came to a halt on this screen.

Your error seems to have nothing to do with your hardware upgrade (I say seems, since it may somehow be affecting the integrity of the kernel). The problem seems to be an error in writing (specifically, unlinking a file) from the filesystem. I would boot to a rescue CD and run fsck on the affected filesystems. Most likely, you have a corrupt journal. If that doesn’t work, you might try booting the operating system and mounting the filesystem as ext2 instead of ext3 (this way, the kernel will ignore the journal).

Hitboxx 10-06-2007 09:47 PM

Thanks for the reply osor, and I'm so glad how wrong can people be, me as well as you :D

I remebered I had also installed the Xen kernel, so using a live-cd, I re-enable it in GRUB, booted into it and it did boot. Then I enabled the nVidia driver using chkconfig and rebooted into my normal kernel and things are back to normal.

A constant process of learning when using Linux, nice :)

All times are GMT -5. The time now is 03:16 AM.