LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 09-23-2004, 01:35 PM   #1
jibranilyas
LQ Newbie
 
Registered: Sep 2004
Location: Chicago
Posts: 7

Rep: Reputation: 0
VNC problem.. please help


I had to reinstall RedHat 2 days ago. Now VNC is not working. I wanted to work from my windows desktop to work on linux system.

Initially i had a problem with getting the GUI, but i edited the Xstartup file to get that working. Now, the problem is that i can't even connect to the terminal.. From other machine... the error i get is host not found... i can ping the IP on linux machine but when enter that in VNC viewer on other machine i.e. 10.0.1.11:1 ... It doesn't work.

here is my log in .vnc folder

Xvnc version 4.0 - built Jun 14 2004 12:01:28
Underlying X server release 40201000, The XFree86 Project, Inc

Thu Sep 23 01:11:50 2004
vncext: VNC extension running!
vncext: Listening for VNC connections on port 5901
vncext: Listening for HTTP connections on port 5801
vncext: created VNC server for screen 0
error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
***********************

If you need, here is the text of my xstartup in .vnc folder

#!/bin/sh

[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &
 
Old 09-23-2004, 03:13 PM   #2
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
Try this for your xstartup:

#!/bin/sh

# Red Hat Linux VNC session startup script
unset SESSION_MANAGER
exec /etc/X11/xinit/xinitrc
 
Old 09-23-2004, 04:21 PM   #3
jibranilyas
LQ Newbie
 
Registered: Sep 2004
Location: Chicago
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks so much for the help
Now, my log file looks like this
VNC still not working...

Xvnc version 4.0 - built Jun 14 2004 12:01:28
Underlying X server release 40201000, The XFree86 Project, Inc


Thu Sep 23 04:17:35 2004
vncext: VNC extension running!
vncext: Listening for VNC connections on port 5901
vncext: created VNC server for screen 0
error opening security policy file /usr/X11R6/lib/X11/xserver/SecurityPolicy
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing from list!
SESSION_MANAGER=local/nagiosmachine:/tmp/.ICE-unix/2610
Window manager warning: Log level 32: could not find XKB extension.
/usr/share/rhn/rhn_applet/rhn_applet.py:362: DeprecationWarning: integer argument expected, got float
self.animate_timeout_tag = gtk.timeout_add(math.floor(1000 * ANIMATION_TOTAL_TIME/len(frames)), self.animate_handler)
 
Old 09-23-2004, 08:49 PM   #4
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
sorry but not sure what else to say.
that is what i have on my redhat box.
 
Old 09-24-2004, 08:36 AM   #5
jibranilyas
LQ Newbie
 
Registered: Sep 2004
Location: Chicago
Posts: 7

Original Poster
Rep: Reputation: 0
I don't see the VNC service there on the "Services" in System tools-->server apps

When it was working it used to be there..

However, I do get the .pid file when i type vncserver on the terminal...

Please let me know if you can narrow it down.. Just tell me what could be and wat CANNOT be the issue, so i don't spend time on configurations that won't help.
 
Old 09-24-2004, 09:25 AM   #6
Finlay
Senior Member
 
Registered: Mar 2003
Location: Seattle
Distribution: Slackware ?-14.1
Posts: 1,029

Rep: Reputation: 47
the process should be called xvnc
make sure you don't have a firewall blocking it

i would uninstall the rpm and install it from source
 
Old 09-24-2004, 10:02 AM   #7
jibranilyas
LQ Newbie
 
Registered: Sep 2004
Location: Chicago
Posts: 7

Original Poster
Rep: Reputation: 0
I went to System Settings-->Server Settings-->Services and couldn't find xvnc... I remember seeing VNC when it used to work,

Hey, can you tell me how to uninstall the rpm and install from source.

I went to the system logs-->Installed RPMS, i saw
vnc-4.0-1.beta4.11.i386.rpm

I think i was using the vnc 3.3.6 before... i want to try uninstalling vnc4.0 and install vnc 3.3.6. i am gonna look for how to do it..
you can tell me if you have time.

Last edited by jibranilyas; 09-24-2004 at 10:08 AM.
 
Old 09-24-2004, 10:57 AM   #8
jibranilyas
LQ Newbie
 
Registered: Sep 2004
Location: Chicago
Posts: 7

Original Poster
Rep: Reputation: 0
Thankyou so much

It was the firewall... Got it
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VNC problem zirtik Linux - Software 6 03-04-2015 05:05 PM
problem with vnc jnev Ubuntu 3 11-23-2005 07:38 PM
VNC problem apolon10 Linux - Networking 5 04-19-2005 02:00 AM
problem, with vnc Paxmaster Linux - Software 4 12-29-2004 12:27 PM
VNC Problem Wolf-67 Linux - Newbie 1 10-01-2004 06:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 06:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration