-   Fedora (
-   -   Vlc / totem (

tm2383 04-14-2013 01:58 PM

Vlc / totem
Hi Folks,
I have Fedora 18 64 bit installed. I cannot get Totem or VLC player to work. I have installed the appropriate codecs. When i try to launch a dvd, the player disappears. I tried launching from the command line and got these errors:


(totem:6355): Grilo-WARNING **: [registry] grl-registry.c:330: Failed to initialize plugin: '/usr/lib64/grilo-0.2/'

(totem:6355): Grilo-WARNING **: [registry] grl-registry.c:330: Failed to initialize plugin: '/usr/lib64/grilo-0.2/'

(totem:6355): Grilo-WARNING **: [registry] grl-registry.c:787: Failed to open module: '/usr/lib64/grilo-0.2/'

(totem:6355): Gtk-WARNING **: GtkMenuBar 0x146b760 is mapped but visible=1 child_visible=1 parent GtkApplicationWindow 0x1009080 mapped=0

and for VLC


VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)
[0xfa6108] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0x1071b28] [cli] lua interface: Listening on host "*console".
VLC media player 2.0.5 Twoflower
Command Line Interface initialized. Type `help' for help.

Fedora reports a problem on boot. A did a bit of research on the problem and found a fix that involved installing gst-libav

I did a search for 'gst-liba'v but could not find a single package. However, i did find a package gstreamer 1.0 libav-based-plu-ins which was already installed. I assume that this is the correct package.

I've tried uninstalling and reinstalling, but with no luck.

On a separate note, even though I have totem set as the default player for DVDs , it does not auto load on DVD inserion. I set totem as the default in SYSTEM SETTINGS / DETAILS. Is there anything else i need to do.

Any help would be much appreciated. Thanks.

John VV 04-14-2013 02:05 PM

did you fallow the mjmwired guide ?

at the top of every page is the bold yellow link to the "Set up guides"
the very first is for Mjmwired

personally i would not use "totem"
but use the QT based front end to mplayer " SMplayer"

tm2383 04-14-2013 04:03 PM

Thanks for the reply. I went to the post installation guide that you suggested and found a lot of useful information. Thanks for the links. I have already installed video codecs following another source. When I followed the info in the links you provided, I generated this error message. Does this mean that I alreadt have a functional set of codecs, LIBDVDCSS installed or do I need to uninstall mine and install the new ones? If this is the case, how do i do this? This is the output:


[root@localhost Downloads]# yum --enablerepo=atrpms install libdvdcss2
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package libdvdcss2.x86_64 0:1.2.11-6.fc18 will be installed
--> Finished Dependency Resolution

Then i get:

Transaction Check Error:
  file /usr/lib64/ from install of libdvdcss2-1.2.11-6.fc18.x86_64 conflicts with file from package libdvdcss-1.2.12-1.fc17.remi.x86_64

Thanks again for all of your help. I appreciate it.


John VV 04-14-2013 04:20 PM

uninstall the fedora 17 rpm you installed on fedora 18
I am betting there are a few other fedora 17 packages you installed on fedora 18
( some are normal and are part of 18 -- they did not change , so there was no reason to repackage them )
-- this will output a list of fedora 17 programs installed on fedora 18

su -
rpm -qa | grep fc17

for this one it is a remi package so


su -
yum remove libdvdcss
------ that should do it , if not then
rpm -e libdvdcss-1.2.12-1.fc17.remi.x86_64.rpm

---- then install the fedora 18 version ---
yum --enablerepo=atrpms install libdvdcss2

tm2383 04-14-2013 05:55 PM

Thanks. The libdvdcss from fc17 was removed and the fc18 version installed no problems. However, DVDs are still not playing and errors in Totem are still being reported. other players are not working either.

Here are the fc17 packages installed. I'm coming from a previous Ubuntu install, where this was maybe less of an issue.


[root@localhost tim]# rpm -qa | grep fc17

Thanks again

John VV 04-14-2013 06:30 PM

totem is really not the best player for store bought dvd's

vlc is
it supports the menus on the dvd

for totem you need the "good, bad, and ugly" GStreamer plugins
-- fedora docs ---
from the gnome totem page

search yum for gstreamer and you will find them

but unless you really WANT totem i would use vlc and smplayer

i normally remove totem from every install as one of the first things i do
-- but that is just my opinion

Ztcoracat 04-15-2013 04:37 PM

When I installed Fedora 17 my videos wouldn't play either--
A friend of mine at Ubuntu told me you need:


In order for VLC to work--

Also I realized that I didn't have flash installed-

tm2383 04-20-2013 08:43 AM

Hi John,
Just a quick update. I think you must have been right about me having installed a lot of incorrect packages. I did a reinstall of Fedora 18 and followed the post install guide that you suggested. Everything works perfectly. Thanks again for the advice.


All times are GMT -5. The time now is 05:30 AM.