LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   very strange swap partition label and empty text console (https://www.linuxquestions.org/questions/fedora-35/very-strange-swap-partition-label-and-empty-text-console-349612/)

whencat 08-03-2005 12:21 PM

very strange swap partition label and empty text console
 
Hai LQ guys,

I recently installed Fedora Core 4 on my system.Right from the time it got installed, it is giving me strange problems.Some of it i cud solve but the following remain a mystery:-

1]Swap did not activate at all and the /etc/fstab looks like this
Start*******************************************************************************************

LABEL=/123 / ext3 defaults 1 1
LABEL=/boot123 /boot ext3 defaults 1 2
/dev/devpts /dev/pts devpts gid=5,mode=620 0 0
/dev/shm /dev/shm tmpfs defaults 0 0
LABEL=/home123 /home ext3 defaults 1 2
/dev/proc /proc proc defaults 0 0
/dev/sys /sys sysfs defaults 0 0
---->LABEL=Talk-IP code wi swap swap defaults 0 0
/dev/hda13 swap swap defaults 0 0
/dev/hda9 /mnt/win_misc vfat defaults 0 0
/dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0

End*********************************************************************************************

See the line marked with ---->the swap partition has a strange label....wat nonsense is this?
is thr some problem with the installation?

the /dev/hda13 was wat i manually added after a great pain [because FC4 did not recognise the swap first.]
then i did a swapon /dev/hda13.............then it worked.
but can someone please enlighten me on wat the default fstab entry means??


2]The text console shows up as an empty screen without any text at all [ctrl-alt-F1 thru ctrl-alt-F6 ....all are empty.............ctrl-alt-F7 is the GUI]

and yes the mingetty process is running neatly .........

4 0 2377 1 18 0 1556 340 - Ss+ tty1 0:00 /sbin/mingetty tty1
4 0 2378 1 19 0 1552 340 - Ss+ tty2 0:00 /sbin/mingetty tty2
4 0 2379 1 19 0 1556 340 - Ss+ tty3 0:00 /sbin/mingetty tty3
4 0 2380 1 19 0 1556 340 - Ss+ tty4 0:00 /sbin/mingetty tty4
4 0 2381 1 18 0 1556 340 - Ss+ tty5 0:00 /sbin/mingetty tty5
4 0 2382 1 18 0 1556 340 - Ss+ tty6 0:00 /sbin/mingetty tty6

what can possibly be the problem?

any help is duly welcome.

kurtdriver 08-03-2005 03:34 PM

I don't know about your first problem, but I share your second one: no virtual consoles since my upgrade, via http to FC4. I hope someone else has an possible answer to our questions. Happy computing, Kurt

jcliburn 08-06-2005 07:11 PM

The first problem (bogus swap label) is a known FC4 bug. Search bugzilla.redhat.com for details if you wish, but essentially, if you manually partition your disks during FC4 installation, the swap label will get corrupted. It works fine if you let the installer auto-partition your disks.

You took the proper corrective action. Well done.

whencat 08-07-2005 01:50 AM

jcliburn,


Yes thanx friend......it seems to be a confirmed bug,i shud hav searched bugzilla befor posting here.
will be careful next time.

BTW,

Does it not seem that FC3 was a better product than FC4......

jcliburn 08-07-2005 10:16 AM

I'm not dissatisfied with FC4.

By the way, my text consoles work fine.


All times are GMT -5. The time now is 01:55 PM.