Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Fedora This forum is for the discussion of the Fedora Project.


  Search this Thread
Old 11-16-2005, 10:10 AM   #1
Registered: May 2005
Posts: 49

Rep: Reputation: 15
using stock kernel with fedora core 4, why make it so hard?

I need to use a stock linux kernel ( for some hard-real time stuff, and I keep having issues with LVM. Specifically, when I go to reboot with the new kernel I get:

Red Hat nash version 4.2.15 starting
Unable to find device-mapper major/minor
Reading all physical volumes. This may take a while...
No volume groups found
Unable to find volume group "VolGroup00"
ERROR: /bin/lvm exited abnormally with value 5 ! (pid 341)

I loaded all the settings in the Fedora kernel config to avoid problems like this, but obviously something is still wrong. I saw a bunch of errors when the config file was loaded, so that's probably the problem.

If I can't get this working with Fedora, can anyone recommend a distribution that's more "vanilla kernel friendly"? i.e. one that will boot if I copy the config it uses to the vanilla kernel.

Old 11-16-2005, 04:13 PM   #2
Senior Member
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
Then donít use LVMs when you install FC4. LVMs are optional, unless you select autopartitioning.

FC4 didnít make it hard, you made it hard. Next time, manually partition during the installation and use conventional partitions.
Old 11-16-2005, 04:33 PM   #3
Registered: May 2005
Posts: 49

Original Poster
Rep: Reputation: 15
That's nice.

In the meantime, would getting my current install to boot from a vanilla kernel require patching it with LVM support, or is there an easier way?
Old 11-16-2005, 05:57 PM   #4
Senior Member
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
Did you enable Device Mapper Support when you compiled?

Old 12-06-2005, 09:56 PM   #5
LQ Newbie
Registered: Dec 2005
Posts: 1

Rep: Reputation: 0
Nick, I was just doing some testing on my system... same problem that you described.

I found this bug report posted on another forum:

Seems to be related to mkinitrd... Long story short, I suspected that perhaps the kernel and mkinitrd get updated in the wrong order with yum, so what I did to fix was remove the latest kernel with:

yum remove kernel-2.6.14-1.1644_FC4

Then simply:

yum update OR

yum install kernel-2.6.14-1.1644_FC4

(to grab the latest kernel again)

Hope this at least gives you a clue (wasn't sure if you're custom compiling?)

Good luck!

Last edited by zonee77; 12-06-2005 at 10:03 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
make errors in fedora core 4 tristanm Programming 12 11-16-2005 03:01 AM
Stock Install of Fedora Core 4 with SELinux SYD2005 Linux - Security 2 06-27-2005 07:31 PM
cant re-make modules with stock source? jgdovin Linux - Newbie 4 06-15-2004 08:02 AM
Upgrading stock 2.4.22 kernel to 2.5.x then to 2.6.6 with existing stock .config file Kyl3 Slackware 8 06-09-2004 05:34 PM
Fedora with a stock kernel Baltasar Fedora 4 01-26-2004 06:03 PM > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 11:00 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration