-   Fedora (
-   -   Upgrading to Firefox 14 on Fedora 15 (

Xotli 07-30-2012 01:09 PM

Upgrading to Firefox 14 on Fedora 15
My Firefox keeps crashing, so I'd like to upgrade it. Here's what I've got now:


Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
firefox.x86_64                                              8.0-3.fc15                                              installed

But I can't figure out how to get yum to find a newer version. I tried the instructions here:

but no joy. Note that the instructions for setting up the rpmfusion repo don't work. I got around this by going to and following the instructions there directly (which I had done previously, but this did update them). The instructions for installing the remi repo worked just fine. But, as you can see, no newer versions of Firefox.

Anybody have any suggestions?

macemoneta 07-30-2012 02:25 PM

Fedora 15 is EOL, so there won't be any new updates for it.
You can upgrade to a newer version (Fedora 17 is current), or you can download the package directly from Mozilla. The directly installed version won't be in your package database (i.e., can't be queried by rpm or yum).

John VV 07-30-2012 04:32 PM

basically you do not on the now DEAD fedora 15

you install the current Fedora 17

note :
the OLD firefox in the OLD base fedora 15 repo is the OLD firefox 3.6 ( yes ff3.6)
it is mostly incompatible with Firefox 14 or 15 testing

Xotli 07-30-2012 08:55 PM

Well, if I could trust Fedora to upgrade properly without destroying my machine, I probably would upgrade my laptop from 15 and/or my workstation from 14. However, experience has taught me that, if I don't want to lose a week reconfiguring and deconfiguring, I'm really better off staying where I am. :-/

FC15 was brand new when I installed it on this laptop only a little over a year ago ... seems like the Fedora lifecycle is getting shorter and shorter. <sigh> Ah, well, I guess I'll just take the suggestion of going directly to Mozilla and around yum altogether.

John VV 07-30-2012 11:03 PM


Well, if I could trust Fedora to upgrade properly without destroying my machine
what do you expect from a Research and Development testing the envelope distro

fedora IS NEVER stable
there is NEVER a "stable" release


seems like the Fedora lifecycle is getting shorter and shorter
no it still is ONLY 13 months
it has been 13 months sense about fedora2

A new and often VERY different OS is released EVERY 6 months

the RECOMMEND ( sense the beginning of the fedora project) is a clean NEW install
back up data
new install

that is the PREFERRED way to "upgrade"

now over the last few years "preupgrade" has gotten "better"
BUT it REQUIRES a 1 gig boot partition , and NOT a 100 Meg partition
and will fail from using third party repos

also fedora 15 IS EOL!!!
DO NOT use a version of fedora that WILL NEVER EVER get ANY security fixes
there will NEVER be any kernel updates to fix KNOWN and NOW fixed issues
there will NEVER be any updates to any programs -- it it DEAD!!!

install fedora 17
then in about 4 mouths instal lfedora 18
then 6 months after that install fedora 19


Use a LONGER life distro !
openSUSE is 18 months
SELD( suse- non free) is 7 YEARS
RHEL is 7 to 10 YEARS

Xotli 08-06-2012 02:52 AM

Well, for those folks who have turned up this thread in a search, and were perhaps hoping for something slightly more helpful than "upgrade your OS, you moron!", I'd like to report that I finally figured out how to do this. Perhaps this will be helpful for other folks as well.

First of all, I wasn't able to find a way to do it with yum. I'm not sure why, but really all the yum is doing for you is working out the dependencies, and I was able to do that by trial and error. So this should work fine.

Fire up your Google and run two searches:


rpm "xulrunner 14" "fedora 15"
rpm "firefox 14" "fedora 15"

This should turn up several links. Make sure you find the one that a) is for your architecture, and b) actually links to an actual RPM. Also, substitute the version of Fedora you have if it's not 15.

If you're not sure what architecture you have, try:


winterfell /var/install # uname -i

If you're not sure what version of Fedora you have, try:


winterfell /var/install # cat /etc/fedora-release
Fedora release 15 (Lovelock)

If you have x86_64 architecture (like me) and you have either Fedora 14 or Fedora 15 (like me), then I can save you some effort:

Download the appropriate two RPMs somewhere. Now, just pop into a root window and type:


yum upgrade libvpx
rpm -Uvh xulrunner14-14.0.1-1.fc15.remi.x86_64.rpm
rpm -Uvh firefox-14.0.1-1.fc15.remi.x86_64.rpm

Again, substituting the appropriate Fedora versions and architectures ... basically, just run "rpm -Uvh" on the two files you just downloaded. But upgrade libvpx first, or it'll whinge at you.

Hope this helps some folks!

All times are GMT -5. The time now is 04:38 PM.