-   Fedora (
-   -   upgrade to FC8 left me with a bad logical volume (

yello 12-03-2007 10:28 PM

upgrade to FC8 left me with a bad logical volume

I recently upgraded to FC8 and when I did a final reboot, my lvm volumes
failed to come back up. Poking around shows that the data on the disk
(happens to be /dev/md1, a RAID5 volume) is still intact, but pvscan, etc.,
report an 'Invalid metadata area header checksum'.

The disk contains a valid physical volume (pv0), volume group (raid5a),
and 3 logical volumes. The disk is intact, but cannot be started by lvm.

Is there a way (via 'dd' or some other fashion) to copy the data off of
this disk and on to another volume such that I can recover the files?

I have other disks available, but don't know how to get the data off in a
form that I will be able to read later. I tried some experiments with
'dd' but couldn't see how I was going to get the files out of it.

Thanks for your help,


abejarano 12-04-2007 03:56 PM

Have you read



yello 12-05-2007 05:46 PM

Thanks, abejarano!

After re-reading the linuxjournal article, I tried removing the PV and
recreating it. This time, I was able to create the VGs and LVs using
'vgcfgrestore'. This is good news. Not sure why it worked, but it did.

The logical volumes are now all ACTIVE.

So, now I have my three logical volumes, but when I try to fsck them,
it tells me there is a bad superblock (on all three). I've tried
specifying a different superblock, but no joy.

I 'grep'ed the volume and my data appears to be there (still).

Any suggestions on mounting these?

When I try to mount one I get:

mount: wrong fs type, bad option, bad superblock on /dev/mapper/vg0-homes,
missing codepage or helper program, or other error



All times are GMT -5. The time now is 06:17 PM.