-   Fedora (
-   -   upgrade from red hat 9 to fedora and lost internet connection (

enchant 01-27-2004 11:28 PM

upgrade from red hat 9 to fedora and lost internet connection

I just updated to fedora core 1 from red hat 9. I found that I cannot connecto to internet. I use a netgear router, 2 PCs are connected to it. The windows xp machines can still connect to internet. When red hat 9 is running, it can also connect without problem.

For the fedora, I noticed that the eth0 is brought up fine. The following is the content from ifconfig :

lo Link Encap:Local Loopback
inet addr: Mask:
RX packets:10 errors:0 dropped:0 overruns:0 frame:0
TX packets:10 errors:0 droppted:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX Bytes:700 (700.0 b) TX bytes:700 (700.0.b)

Any help will be greatly appreciated !



mike_loux 01-28-2004 08:32 AM

Do you have a 3Com 3C905 card? There is a bug in Fedora that kills the network for this particular card. when the kudzu service (which handles re-probing changed hardware) is enabled. Disable this service in all runlevels and you should be all set.

enchant 01-28-2004 09:13 AM


I don't remember what ethernet card I have, but it is not 3Com. I am away from my computer, so I could not check.

In my original question, I stated the eth0 is brought up, but I was wrong. sorry. :)

From the logs, I noticed that modeprob is looking for /lib/modules/ And I only have /lib/modules/ I don't even have the directory. I create directory and copied the /lib/modules/ over. Doesn't work, said something about "not ELF format". I then delete the copied modules.dep file and create a symbolic link to /lib/modules/
Doesn't work either, and this time modules.dep in /lib/modules/ is empty !

How do I generate a modules.dep file ?
Is modules.dep generated at boot time ? How does modeprob work ? Is there a way to specify which directory to look for modulles.dep file ?

Thanks in advance,


enchant 01-28-2004 09:27 AM


A different question ( maybe related ). My /usr directory is mounted on its own partition. In the /etc/fstab file, it looks like this

/dev/hdb6 /usr ext3 default 1 3

Fedora couldn't mount this drive ! saying the kernel does not support ext3 filesystem. Is it, really ? As a result, besides losing a bunch of shell command, X window won't start. I have to change to

/dev/hdb6 /usr ext2 default 1 3

then x-window works. What went wrong here ?



nsample 02-02-2004 02:01 AM

I have the very same issue! I can manually go in an restart the network card (on eth0, not 3COM)... but it won't survive a reboot, even though I save the settings. Any help?

mike_loux 02-02-2004 08:41 AM

Have you guys tried disabling kudzu on the appropriate runlevels anyway, just to see what happens? The error doesn't occur on only 3Com cards; 3com just happens to be the most visible of the bunch.

Also, from doing some reading, the problem seems to be partially rooted in the 2.4 kernel. Apparently the problem doesn't exist in 2.6 (but 2.6 is still being tested, so don't expect to see it for a while).

enchant 02-02-2004 10:49 AM

Hi Guys,

For me the problem lies in the following : prior to upgrading, I was using lilo, and upgrading to Fedora did not upgrade /etc/lilo.conf properly. So when booting, some "stripped-down" kernel was load in. Fixing lilo.conf solves the problem. Now I am using grub which is really better.

I just build kernel 2.6.1 from source this weekend and I can use a proper Nvidia driver :). Besides looking better, I really didn't see any difference. Probably because that is very old macine ( P 3 ) and I was justing doing some web browsing with it.

In /usr/src, there is a symbolic link linux-2.4 which points to linux2.4.22..... (
the one that comes with FC1 ). Does anyone know what this link does ?



All times are GMT -5. The time now is 02:57 AM.