-   Fedora (
-   -   updated kernel crashes (

boaojatista 05-23-2006 08:27 AM

updated kernel crashes - Resolved
Hi everybody,
I have successfully installed FC5 in my new home computer, but I can not update the kernel because it crashes in the boot process. I have posted a bug in Fedora's bugzilla but I understand that people there must be very busy and maybe be the problem is not so serious once I can run the kernel shipped with the CD's. But in my point of view this is serious enough to make me consider to change to other distro, since by now I can not even install special drives for my Radeon graphic card (OK it runs with vesa module, but, again...). I have also posted this in the Fedora forum but got no answers. Maybe someone can point for a place where I can dig more information and solve the problem. Here follows basic information about my configuration and a copy of the screen I got when try to boot from a regularly updated kernel (yum update...). This happened with versions 2.6.16-1.2096, 2.6.16-1.2111 and yesterday with 2.6.16-1.2122.
AMD 64 3000+
I am using a ASUS A8N-E motherboard with nvidia sata controller.
The RAID BIOS support is enabled
I am using LVM and hardware RAID 0 with 2 sata HDs
FC5 686 kernel version 2.6.15-1.2054

This is what I see in my screen when I try to reboot with the newly installed kernel:


Root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /vmlinuz-2.6.16-1.2122_FC5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
[Linux-bzImage, setup=0x1e00, size=0x16e862]
initrd /initrd-2.6.16-1.2122_FC5.img
[Linux-initrd @ 0x37e3c000, 0x1b3698 bytes]

Uncompressing Linux... Ok, booting the kernel.
Red Hat nash version 5.0.32 starting
device-mapper: dm-stripe: Target length not divisible by chunk size
device-mapper: reload ioctl failed: Invalid argument

Unable to open /dev/mapper/nvidia_acaafeee – unrecognised disk label.
Reading all physical volumes. This may take a while...
No volume groups found
Unable to find volume group “VolGroup00”
Unable to access resume device (/dev/VolGroup00/LogVol01)
mount: could not find filesystem `/dev/root`
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic – not syncing: Attempted to kill init!

I have tried to create new initrd images explicitly loading dm and nvidia controller modules but it doesn't work.
So, any help will be welcome. Or maybe the best solution is to move to another distro wich doesn't have this kind of problem.
Thank you for the attention

P.S. 27/05/2006
I have it working now. Visit this link so you know your whereabouts and follow this procedure :

1)Download mdraid-rpm mentioned in bugzilla and install it
2)fix the raid size by typing “dmraid -a n && dmraid -a y”
3)remove kernel 2.6.16 (if installed)
4)install the kernel again (this generate a proper initrd)
5)reboot and be happy

TruongAn 05-23-2006 09:52 AM

Have you checked the configuration of your kernel?
I think it look likely that you have turn off the support for LVM.

boaojatista 05-23-2006 11:00 AM

I think that I have LVM support enabled because I am running FC5 kernel 2.6.15-1.2054 using LVM. Only when I update the kernel with yum (regular update) that I am not able to boot from the new kernel. So do you think that the update process is disabling that support only for the new kernel ? I have tried to create new initrd version asking explicitly to include dm and sata_nv modules to be included. But, I think there is something in this direction and the problem is related to the update process. Maybe there is another place where I can find some help but I dont know where.
Thank you, anyway

PTrenholme 05-23-2006 11:18 AM

Check your /etc/udev/ entries. /dev/mapper is created by udev, and -- from your (repeated) failures to boot, I suspect that your problem is there.

You did, I hope, read the FC5 release notes concerning udev, and how to set it up.

FYI: Here's what a (slightly modified) start of the nash init file looks like. (The setquiet command at the start suppresses all the echoed stuff, so you don't usually see that.)


mount -t proc /proc /proc
echo Mounted /proc filesystem
echo Mounting sysfs
mount -t sysfs /sys /sys
echo Creating /dev
mount -o mode=0755 -t tmpfs /dev /dev
mknod /dev/console c 5 1
mknod /dev/null c 1 3
mknod /dev/zero c 1 5
mkdir /dev/pts
mkdir /dev/shm
echo Starting udev
echo -n "/sbin/hotplug" > /proc/sys/kernel/hotplug
echo "Loading dm-mod.ko module"
insmod /lib/dm-mod.ko
echo "Loading jbd.ko module"
insmod /lib/jbd.ko
echo "Loading ext3.ko module"
insmod /lib/ext3.ko
echo "Loading dm-mirror.ko module"
insmod /lib/dm-mirror.ko
echo "Loading dm-zero.ko module"
insmod /lib/dm-zero.ko
echo "Loading dm-snapshot.ko module"
insmod /lib/dm-snapshot.ko
/sbin/udevstart # <- To set up for the device mapper, I think
echo Making device-mapper control node
mkdmnod # <-- Here's where your problem message is generated
echo Scanning logical volumes # <- I think that LVM is always in the Fedora core unless you compile your own verson.
lvm vgscan --ignorelockingfailure
echo Activating logical volumes
lvm vgchange -ay --ignorelockingfailure

boaojatista 05-23-2006 12:32 PM

Maybe we've got some light here finally. I am sorry but I did not check udev's release notes. I did not even know I had to setup udev. Where are them ?? But it is my understanding that udev starts to run after the filesystems are mounted. Am I wrong ?? And why it works when I boot with the older kernel and not with the new one? Anyway I checked /etc/udev, here is the output :

[root@CedarCourt rules.d]# pwd
[root@CedarCourt rules.d]# grep mapper *
50-udev.rules:KERNEL=="device-mapper",  NAME="mapper/control"

I removed the quiet option and I can see there is lot of stuff before the error appears. Is there a way to show them in a slower way ?
Maybe now we are in a hot track. Thank you.:)

PTrenholme 05-24-2006 04:30 PM

For the release notes, look in /usr/share/doc/fedora-release-5/.

As to slowing down the output during boot, the "Scroll Lock" key sometimes works. (Depends on your keyboard, I believe.)

Here's a link to the udev rule writing article referenced in the notes:

boaojatista 05-25-2006 12:50 AM

Ok. I did read the instructions! But I still could not get what exactly I have to do since there already is an entry for device-mapper at /etc/udev/rules.d/50-udev.rules and fstab does list logical volumes. I tried to create initrd images files (with -v option) and I could observe that it is loading the appropriate modules (dm-* and sata_nv) in the initrd image. I can boot with them but, again, only the original version of the kernel (2.6.15-1.2054) goes well. Obviously I have tried to use the scroll-lock key, but it did not work very well. I can see messages of loading the dm-* and scsi and sata_nv modules when I am booting the old kernel but not when I am booting the new ones. I am saying that I can't see the messages and not that the modules are not loading (scroll-lock key). It is hard to understand why it happening because it runs very well with the 2.6.15 version. I can not believe that the newer kernels do not have this kind of support. Next thing I am considering to try is to generate the new version myself. I really think that is important to be able to update the kernel although the only problem I am having now is that I cannot load the ATI video driver. Maybe I should join some mailing list or look for help elsewhere. I am willing to accept suggestions. I think that it is something related to the initrd process. Is there a way to load a module trough an option in grub.conf ?
Is it possible that I am the only one having this kind of problem ? Raid and lvm are becoming very popular and I should expect to find many people using them. Any help is welcome.
Thank you.

PTrenholme 05-25-2006 09:31 AM

Re the ATI driver -- Did you read the "sticky" note in the first line of the Fedora forum about ATI and nVidia drivers? Basically, the recommendation is to only use precompiled drivers from sites like livna.

You might find this thread interesting. It's talking about problems with the nVidia CK804 driver on AMD 64 processors. Further down in the thread there's a "patch" to the driver code proposed. (Having neither an AMD 64 system, nor a nVidia controller, I didn't read the whole thing. But a quick Google for nvidia and ck804 turned up lots of "problem' reports.)

boaojatista 05-25-2006 09:52 PM

Well, the thread code is a little deep for me. Is useful to know that there is somebody taking care of it. But I still dont understand why it only crashes with updated kernels. It makes me think that there is something wrong in the update process and Anaconda does the right thing at installation time. About the video drivers, my intention is to install them from livna. And I will have to do it since the official one doesnt have a good performance so watch dvds is painful.
Thanks for your attention.

jayqiu 05-25-2006 10:37 PM

/boot partition don't support lvm,if you want to use lvm,you must take the /boot partition out the lvm, you try it

boaojatista 05-26-2006 07:56 AM

Ok thanks, but the boot partition is out of lvm
Here is fstab :

[killar@CedarCourt ~]$ cat /etc/fstab
/dev/VolGroup00/LogVol00 /                      ext3    defaults        1 1
/dev/VolGroup00/aux1 /aux1                  ext3    defaults        1 2
/dev/VolGroup00/homefake /aux2                  ext3    defaults        1 2
/dev/VolGroup00/lvol0 /aux3                  ext3    defaults        1 2
LABEL=/boot            /boot                  ext3    defaults        1 2
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                  /dev/shm                tmpfs  defaults        0 0
proc                    /proc                  proc    defaults        0 0
/dev/VolGroup00/tmpfake /resto                  ext3    defaults        1 2
sysfs                  /sys                    sysfs  defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0

And I am able to boot this configuration when I am booting 2.6.15-1.2054 kernel (installed by Anaconda at installation).
Any other thoughts ?

PTrenholme 05-26-2006 10:07 AM

IIRC, one of comments in the thread was that the nv disk driver was re-written (or changed) for the 2.6.16 kernel, so it working with the 2.6.15 kernel may not be unexpected.

Fedora Core 5 now has 2.6.16-1.2122 available from the updates repository. You might want to look at the release notes to see if it includes a fix for the nVidia disk driver.

boaojatista 05-26-2006 02:35 PM

I just was realizing that the problem is related to kernel version 2.6.16-* . Yesterday I installed a IDE disk im my machine. Then I installed FC5 (version 2.6.15-1.2054) and updated to the most recent kernel version. So now I have two VolumeGroups:
VolGroup00 : 2 Samsung s-ata 250G with RAID 0 enabled in the controller.
VolGroup01 : 1 IBM IDE 25 G

FC5 is installed in both disks and 2 kernel version in each (2.6.15-1.2054 and 2.6.16-1.2122). So now when it boots the 2.6.15.-1.2054 version, I have no problems it doesn't matter from wich disk I am booting. But when I use kernel version 2.6.16-1.2122 it issues the same error related to VolGroup00 and the only difference is that when I use IBM disk it boots anyway because it does not need anything from VolGroup00. I have debug option turned on in the grub.conf file and the error is the same :

device-mapper: dm-stripe: Target length not divisible by chunk size
I will try to post this bug in a kernel related mailing list.

TruongAn 05-27-2006 01:29 AM

Just an idea: If I were you, I would compile the kernel from source.
By compiling, I can control what option to be turn on or off and make it optimize for my computer.
You have a very strong CPU, compiling take you just a few minutes, why don't you try it

PTrenholme 05-27-2006 10:51 AM


Originally Posted by boaojatista
[snip]I will try to post this bug in a kernel related mailing list.

Just a thought: You might want to look at the nVidia site to see if they offer a Linux driver for your configuration. If it's like nVidia's video drivers, the Fedora policy forces Fedora to use non-proprietary versions (i.e., written from scratch, using whatever specifications nVidia has released) of the nVidia drivers rather than the binary drivers released by nVidia.

All times are GMT -5. The time now is 08:03 PM.