-   Fedora (
-   -   Updated FC3. Now I can not get desktop back (

fredantrobus 12-24-2004 01:41 AM

Updated FC3. Now I can not get desktop back
I updated FC3 on Tuesday with the latest updates.
After the updates were complete and successfull I shut down then the computer

The next day I powered up the box and xwindows would no longer start.
I got a message about "x restarting to fast retry in 5 minutes"
I googled for tte error message and found several messages about this problem.
Apparently the path to the shared libibraies got toasted.
I did the export:
export LD_LIBRAY_PATH=/lib:/usr/lib:/usr/local/lib

xwindows now starts with out the error messages
but I have lost my gnome desktop

How did I get my desktop back?


trey85stang 12-24-2004 10:44 PM

were you running the nvidia module?? I ran all myupdates earlier today.. and I lost all my opengl files libraries.. having a heck of a time getting 3d working again??

wiraone 12-25-2004 10:50 AM

Wrong move .. I did an update last night and I couldn't get X to start at all .. am getting error saying about xmbind .. cannot open shared object .. and another one error which I couldn't capture. What's give?

I did a ldconfig -v and found out that I lost many libraries .. what I've done wrong? Does this has to do with selinux?

gadago 12-30-2004 03:32 PM

Has any come to find a fix for this issue, I am too having the same problem and desperately trying to avoid a reinstall?? If it is of any help I do have SELinux enabled... is there some way of doing a kind of restore to before the libs where updated?

gadago 12-30-2004 04:18 PM

anyone know how replace the file to point to by library locations?

fredantrobus 12-30-2004 08:00 PM

No one seems to have found a sloution yet.
I have tried a variety of things but so far no luck.

Tonight I will have some actual time to dig into it.

Its amazing how work gets in the way of getting things done.


wiraone 12-31-2004 10:42 AM

I did a quick method .. fresh install .. copied the updates (from yum & apg-get caches) into my /home and reapplied the updates once again after I finished with the reinstallation. Got no time to fiddle around finding what causing it ..

fredantrobus 01-03-2005 10:21 PM

Partial fix figured out
I found that the when I ran ldconfig,
I got a list of .so files that the system could not see even though the files were installed.

I looked up which rpm packages provided the .so in question and then did a

rpm -Uhv --force <packagename>

and forced a reinstall of the package in question.
I did this for each of the error messages and then I rebooted the box.

I could then log in as root or as an other user.
I never could log in as myself.

I copied off my home directory, deleted myself as a user removing my home directory.
Then I added myself back into the system as a user again and copied my files back to my home directory.

I now can login and have a gdm desktop.
Don't know exactly what happened but I am back up and functioning again.


All times are GMT -5. The time now is 07:51 PM.