LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 01-15-2004, 12:41 PM   #1
grapier
LQ Newbie
 
Registered: Dec 2003
Posts: 16

Rep: Reputation: 0
update problems yum/apt-get


When I try to install yum rpm, I get:

warning: yum-2.0.4-2.fd.fr.i386.rpm: V3 DSA signature: NOKEY, key ID e42d547b
error: Failed dependencies:
/sbin/service is needed by yum-2.0.4-2.fd.fr
gnupg is needed by yum-2.0.4-2.fd.fr


Similary when I do apt-get upgrade, I get something I'll post below (cos it's long). It seems the problem is it can't find /sbin/service, which does exist, and /sbin is in my PATH. What's wrong?

Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
XFree86-xfs: PreDepends: initscripts but it is not installed
PreDepends: sed but it is not installed
acpid: PreDepends: /sbin/service
apmd: PreDepends: initscripts (>= 5.53) but it is not installed
aumix: Depends: initscripts (>= 4.42) but it is not installed
autofs: Depends: /bin/ps
Depends: sed but it is not installed
bind: Depends: /bin/usleep
PreDepends: sed but it is not installed
cups: PreDepends: /sbin/service
cyrus-sasl: PreDepends: /sbin/service
desktop-printing: Depends: redhat-config-printer-gui (>= 0.6.67-1) but it is not installed
dev: PreDepends: sed but it is not installed
devlabel: Depends: initscripts (> 6.97-1) but it is not installed
Depends: sed but it is not installed
dhclient: Depends: initscripts (>= 6.75) but it is not installed
firstboot: Depends: redhat-config-packages but it is not installed
foomatic: PreDepends: initscripts but it is not installed
gcc: Depends: binutils (>= 2.14.90.0.4-4) but it is not installed
Depends: glibc-devel (>= 2.2.90-12) but it is not installed
gcc32: Depends: binutils (>= 2.12.90.0.20-1) but it is not installed
Depends: glibc-devel (>= 2.2.90-12) but it is not installed
glibc-kernheaders: PreDepends: initscripts (>= 5.83) but it is not installed
gtkam: Depends: libgphoto2.so.2
Depends: libgphoto2_port.so.0
hwcrypto: PreDepends: /sbin/service
isdn4k-utils: Depends: initscripts (>= 5.92) but it is not installed
kbd: PreDepends: initscripts (>= 5.86-1) but it is not installed
PreDepends: sed but it is not installed
kdegraphics: Depends: libgphoto2.so.2
Depends: libgphoto2_port.so.0
kernel#2.4.22-1.2115.nptl: PreDepends: initscripts (>= 5.83) but it is not installed
kernel-utils#1:2.4-9.1.101.fedora: PreDepends: /sbin/service
nfs-utils: Depends: sed but it is not installed
nss_ldap: Depends: nscd but it is not installed
PreDepends: sed but it is not installed
ntp: PreDepends: sed but it is not installed
openssh: PreDepends: initscripts (>= 5.20) but it is not installed
oprofile: Depends: binutils but it is not installed
pam: Depends: initscripts (>= 3.94) but it is not installed
PreDepends: sed but it is not installed
portmap: Depends: initscripts (>= 5.54) but it is not installed
quota: Depends: initscripts (>= 6.38) but it is not installed
redhat-config-network-tui: Depends: initscripts (>= 0:5.99) but it is not installed
redhat-config-proc: Depends: procps but it is not installed
rhgb: Depends: initscripts (>= 7.22-1) but it is not installed
rp-pppoe: PreDepends: /sbin/service
Depends: initscripts (>= 5.92) but it is not installed
samba: Depends: initscripts (>= 5.54-1) but it is not installed
PreDepends: sed but it is not installed
sendmail: PreDepends: sed but it is not installed
up2date: Depends: gnupg but it is not installed
vixie-cron: PreDepends: /sbin/service
vsftpd: PreDepends: /sbin/service
xinetd: PreDepends: /sbin/service
Depends: initscripts but it is not installed
ypserv: PreDepends: /sbin/service
yum: PreDepends: /sbin/service
E: Unmet dependencies. Try using -f.
 
Old 01-20-2004, 08:33 AM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 475Reputation: 475Reputation: 475Reputation: 475Reputation: 475
Is /sbin/service installed? If not you will need to install it first - try www.rpmfind.net for the download.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum update dependency problems DJOtaku Fedora 6 12-11-2005 02:56 PM
yum update problems jjbuchan Fedora 5 11-02-2005 02:28 PM
Yum Update Problems djljjm Linux - Newbie 2 03-15-2005 03:35 PM
[SOLVED] apt-get update problems adityavpratap Debian 9 01-04-2005 03:51 AM
boot problems after yum update evasion81 Red Hat 1 12-17-2004 11:50 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 04:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration