-   Fedora (
-   -   update errors (

gibbylinks 11-11-2003 11:30 AM

update errors
I get this error when I try to update with yum

[gibbylinks@localhost gibbylinks]$ yum check-update
Gathering header information file(s) from server(s)
Server: Fedora Core 1 - i386 - Base
Error - /var/cache/yum/base/ cannot be found
Please ask your sysadmin to update the headers on this system.
[gibbylinks@localhost gibbylinks]$

And this error when I try to use rhn

This system may not be updated until it is associated with a channel.

The rhn error has only appeared since I deleted my RH9 system on Redhats web site and tried to register with the Fedora, but you don't get a product code so what do ya do ?

Anyone any ideas ??

ronss 11-12-2003 06:52 AM

have you ran yum update yet, do that first-

open terminal
log in as root
run -yum update

after installing the packages, then run yum check-update

gibbylinks 11-12-2003 08:30 AM

I have now managed to get both yum and rhn working, although rhn doesn't give me nowhere near the updates avaliable that yum does.

I still have a problem though, when I try to run yum install I'm getting the following errors

warning: rpmts_HdrFromFdno: V3 DSA signature: NOKEY, key ID 8d f56d05
Error: Could not find the GPG Key necessary to validate pkg /v ar/cache/yum/fedora-extras/packages/wxGTK2-2.4.2-0.fdr.1.1.i38 6.rpm
Error: You may want to run yum clean or remove the file:
/var/cache/yum/fedora-extras/packages/wxGTK2-2.4.2-0.fdr.1.1. i386.rpm
Error: You may also check that you have the correct GPG keys i nstalled

Although I have been to the site and run the following when logged in as root in a terminal window.

rpm --import

And I got no errors when I ran the command.

Can anyone shed any light ??


wiraone 11-12-2003 09:02 AM

I had the same problem before, you may want to download wxGTK from the following site:

name=Fedora Core 1 -- Fedora US mirror

name=Fedora Core 1 updates -- Fedora US mirror

name=Fedora Linux (stable) for Fedora Core 1 -- Fedora US mirror

All times are GMT -5. The time now is 03:20 PM.