-   Fedora (
-   -   Uninstall Netflix Player (

tm2383 03-22-2013 04:51 PM

Uninstall Netflix Player
Hi everyone,
I installed Netflix Player on Fedora 18 64 bit, using the instructions below:


su -c ‘yum -y install wget’

wget -c

tar -xvzf Netflixplayer.tar.gz

su -c ‘sh’

to run:

sh /usr/bin/

I am trying to uninstall it as I have found out that it does not work on 64 bit! This was a complex install which installed a wine wrapper around Netflix player. When I use yum remove Netflix, the package is not removed. I want to remove it from my computer, or at the very least, the cinnamon launch menu.

Can anyone help?



John VV 03-22-2013 08:44 PM

yum will not uninstall a program you installed using a install script ""

you have to use that script to uninstall it

if you read the shell script it likely has a uninstall option
likely something like this

su - --uninstall

but it might not

if not read the script and manually undo what it did

----- edit ---
this is why i hate auto exe packages

it is looking like it installs /Mozilla/firefox.exe
and /usr/bin/
you are going to have to manually find all it's bits and manually remove them , one at a time .


I am trying to uninstall it as I have found out that it does not work on 64 bit!
have a look at the fedoraforum page

you need to install ALL of the 32 bit compatibility software
--- a very long list ---

su -
--- your root password when asked ---
yum -y install --skip-broken arts.i686 audiofile.i686 bzip2-libs.i686 cairo.i686 compiz.i686 cyrus-sasl-lib.i686 dbus-libs.i686 directfb.i686 esound-libs.i686 fltk.i686 freeglut.i686 gtk2.i686 hal-libs.i686 imlib.i686 lcms-libs.i686 lesstif.i686 libacl.i686 libao.i686 libattr.i686 libcap.i686 libdrm.i686 libexif.i686 libgnomecanvas.i686 libICE.i686 libieee1284.i686 libsigc++20.i686 libSM.i686 libtool-ltdl.i686 libusb.i686 libwmf.i686 libwmf-lite.i686 libX11.i686 libXau.i686 libXaw.i686 libXcomposite.i686 libXdamage.i686 libXdmcp.i686 libXext.i686 libXfixes.i686 libxkbfile.i686 libxml2.i686 libXmu.i686 libXp.i686 libXpm.i686 libXScrnSaver.i686 libxslt.i686 libXt.i686 libXtst.i686 libXv.i686 libXxf86vm.i686 lzo.i686 mesa-libGL.i686 mesa-libGLU.i686 nas-libs.i686 nss_ldap.i686 cdk.i686 openldap.i686 pam.i686 popt.i686 pulseaudio-libs.i686 sane-backends-libs-gphoto2.i686 sane-backends-libs.i686 SDL.i686 svgalib.i686 unixODBC.i686 zlib.i686 compat-expat1.i686 compat-libstdc++-33.i686 openal-soft.i686 alsa-oss-libs.i686 redhat-lsb.i686 alsa-plugins-pulseaudio.i686 alsa-plugins-oss.i686 alsa-lib.i686 nspluginwrapper.i686 libXv.i686 libXScrnSaver.i686 qt.i686 qt-x11.i686 pulseaudio-libs.i686 pulseaudio-libs-glib2.i686 alsa-plugins-pulseaudio.i686 libtxc_dxtn.i686

and "opencl-utils"

su -
--- your root password when asked ---
yum install opencl-utils

? should be installed ???
but if not

su -
--- your root password when asked ---
'yum -y localinstall'

tm2383 03-23-2013 05:43 AM

Thanks for the very detailed reply. I tried to add the compatabilty software to make Netflix work in 64 bit. However, I got ths error message:

Error:  Multilib version problems found. This often means that the root
      cause is something else and multilib version checking is just
      pointing out that there is a problem. Eg.:
        1. You have an upgrade for mesa-libGL which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of mesa-libGL of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude mesa-libGL.otherarch ... this should give you an error
            message showing the root cause of the problem.
        2. You have multiple architectures of mesa-libGL installed, but
            yum can only see an upgrade for one of those arcitectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
        3. You have duplicate versions of mesa-libGL installed already.
            You can use "yum check" to get yum show these errors.
   can also use --setopt=protected_multilib=false to remove
      this checking, however this is almost never the correct thing to
      do as something else is very likely to go wrong (often causing
      much more problems).
      Protected multilib versions: mesa-libGL-9.1-3.fc18.i686 != mesa-libGL-9.1-1.fc18.x86_64

I've just spent the best part of a day moving from Linux Mint 14 to Fedora 18. I don't want to break the install. Is the installation of these packages safe, do you think?

Thanks again for the reply,


John VV 03-23-2013 12:41 PM

yum errors , fun
is in conflict with


su -
yum update mesa*

if that dose not work

remove the 32 bit version then update and reinstall the 32 bit

su -
yum remove mesa-libGL-9.1-3.fc18
yum update
yum install mesa-libGL.i686
( double check the name with "yum search mesa" )

there is also a new version
a fedora 18 rpm "netflix-desktop-0.2.2-1.fc18.noarch.rpm"

tm2383 03-23-2013 06:41 PM

Thanks John,
I did the Mesa update and everything worked fine. Netflix is now installed and working. Thanks again for all the help.


All times are GMT -5. The time now is 08:52 PM.