-   Fedora (
-   -   Unable to open firefox from evolution - always opens Mozilla (

tog 06-18-2004 05:50 PM

Unable to open firefox from evolution - always opens Mozilla
I am running Fedora Core 2, and I would like the following behaviour:

1. Clicking on a link in Evolution should open up Firefox, if Firefox is already up, and Mozilla, if not.

I realize that this is the default behaviour, and until FC2, it was working fine. But, now, all links open ONLY Mozilla, regardless of whether Firefox is up or not. My default browser is set up as Mozilla. There have been a number of suggestions in the posts (which I state below), but have not worked.

I have tried the following:

1. Replaced /usr/bin/mozilla with a link to firefox. When I do that, it opens firefox but expects another profile, as the default is already in use. Creating a new profile for each link is probably not wise :-)
2. Created a shell script that opens up Firefox, but the browser opens up empty. The script is:
$FIREFOX_PATH/firefox -remote "openURL($@, new-tab)" || exec $FIREFOX_PATH/firefox "$@";

3. Changed Gnome preferences to point to Firefox, as /usr/local/firefox/firefox %s, but again, every click asks for a different profile.
4. If Firefox is up, and I type Mozilla in my shell, it should really open up another instance of firefox. But, for me, it really opens up Mozilla, rather than Firefox. I am running Mozilla 1.6, and Firefox 0.9.

How do I restore the default behaviour. That is, if firefox is up, mozilla should open up another instance of firefox, and not mozilla.



tog 06-19-2004 01:01 PM

I finally gave up trying to figure out why it was not working, and installed Firefox 0.8 from RPMS into a different location from Firefox 0.9. Here is what happened.

1. The rpm install was recognized by the gnome menu, unlike the 0.9 install
2. A choice for firefox appeared when I wanted to set up the default browser in preferred applications
3. Now, if I have firefox 0.9 up, and I click on a link in Evolution, it will open up firefox 0.9, and not firefox 0.8, or mozilla.

So, for the added hard drive space of installing firefox 0.8, I have a solution for my problem. Though not an elegant one.


All times are GMT -5. The time now is 04:29 AM.