-   Fedora (
-   -   Unable to create a KVM in Fedora 7, please HELP (

lighthouse 09-17-2007 10:38 AM

Unable to create a KVM in Fedora 7, please HELP
I am trying to create a QEMU/KVM for a fedora virtual machine using Virtual Machine Manager v 0.4.0.

Step 1. Create a new fully virtualized with x86_64 architecture amd hardware acceleration ticked
Step 2. Use DVD drive with OS Type Linux and OS Variant Fedora 7
Step 3. Use a Simple File for the storage space which is allocated and formated OK
Step 4. Use Virtual Network selection with default
Step 5. Use 2048 MB of a possible 4096 MB an 1 of a possible 2 cpu's
Step 6. Click finish and get the following message:

Unable to complete install: 'virDomainCreateLinux() failed QEMU quit during console startup

Unable to complete install '<class 'libvirt.libvirtError'> virDomainCreateLinux() failed QEMU quit during console startup

Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/", line 681, in do_install
dom = guest.start_install(False, meter = meter)
File "/usr/lib/python2.5/site-packages/virtinst/", line 710, in start_install
return self._do_install(consolecb, meter)
File "/usr/lib/python2.5/site-packages/virtinst/", line 727, in _do_install
self.domain = self.conn.createLinux(install_xml, 0)
File "/usr/lib64/python2.5/site-packages/", line 563, in createLinux
if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: virDomainCreateLinux() failed QEMU quit during console startup

Any ideas anyone??

lighthouse 09-17-2007 08:08 PM

It seems that the maximum amount of memory that QEMU support is 2047MB so once I reduced the max memory to 2000MB everything was sweet. I would have thought simple validation of the maximum memory when running the wizard to create a VM would't be that hard. Oh well - alls well that ends well!!

dob12460 03-27-2008 07:23 AM

I got the same error but with F8 on a 32 bit machine, 4G of RAM available and I specified 512 for the VM. I dropped it back to 256 and it worked. It may work with a higher value, but I guess there's a relationship between x86, 86_64 and max RAM in VM that I don't know about.


dreamland 04-16-2009 08:14 AM

I've got the same error after finishing creating the vm in F9 on a Dell PowerEdge 2850 which is a 64 bit platform but do not have virtualization support in CPU. I used the same config as lighthouse and reducing the memory to less than 2048 solved my problem.
Interesting is that this vm ran perfectly on PowerEdge 2950 (which has CPU virtualization support in BIOS), but we decided to move it to a less used server. After recreating the machine with the same disk we got into trouble. I haven't tried a BIOS update yet for 2850 ...
So ... think this issue is also platform dependent, but reducing the memory should do the trick.

All times are GMT -5. The time now is 05:29 AM.