-   Fedora (
-   -   Unable to access the internet through firefox when switching from school to home (

jalsk 07-27-2006 12:47 AM

Unable to access the internet through firefox when switching from school to home
I am running Fedora Core 5 on my laptop which I take back and forth between school and home. Everything seems to be happy when I am at school using their internet connection, but things slow to a crawl when I'm at home using my dsl connection. The interesting thing is that it really only appears to be with firefox that these slow-downs occur. If I open Konquerer, browsing the internet is relatively quick.

My laptop is a Compaq Presario V4000 running a 1.73Ghz Centrino Processor with 1GB of PC2700 DDR RAM, an 80GB 5400 RPM Hard drive, and an Intel Pro/Wireless 2200BG Wireless card. I am running a customized 2.6.17 kernel. I use KDE 3.5 as my display manager.

When I'm at school, I have a proxy set on my laptop, however I turn that off when I'm at home. I'm at a loss as to exactly what the problem could be. Any help would be greatly appreciated.


Lenard 07-28-2006 09:13 AM

As an experiment try removing the /etc/resolv.conf file and retarting the network service, as root type comething like;

rm /etc/resolv.conf
service network restart

Note: you will have to do something like this when moving from one place to another unless you start using profiles for this.

jalsk 07-28-2006 12:02 PM

Thanks for the reply, but in waiting for a response, I found out that it is not a problem with my laptop, but rather a problem with my dsl modem. I opened Ethereal to try and figure out what the problem might be, and I found out that the modem was resolving ip addresses to, thus my network problems. I'm going to be calling my ISP and getting a new modem. Thanks for the efforts though.


terracotta 07-30-2006 08:41 AM

Being able to browse in Firefox through one router but not another, and then being able to browse with Konqueror when you can't (or only very slowly) with Firefox is indicative of an IPv6 problem. Absolutely 150% sure! ;)

To prove this, disable IPv6 in Firefox. Type 'about:config' in the address bar (without the quotes). Then 'ipv6' (again no quotes) in the filter. You'll see a line beginning 'network.dns.disableIPv6...' Double (or right) click on 'false' to change it to 'true'. Close Firefox and open it again. Now you can browse OK, can't you? And addresses resolve promptly don't they? :)

This problem is often caused by older firmware in routers that cannot handle IPv6 modified IPv4 addresses. So if you get a replacement router of the same make and model you may still have the same problem - unless you are lucky enough to get one with later (and improved) firmware. If all else fails try searching this forum for disabling IPv6 system-wide. You have to edit a couple of lines in a system file, but I can't remember the details at the moment. You need a system-wide fix, rather than just disabling IPv6 in Firefox, because the yum-based utilities will probably be affected as well. They certainly were in FC3 and FC4 when I was plagued by this issue. I don't know about FC5, but I'm sure it's still so.

All times are GMT -5. The time now is 04:34 AM.