-   Fedora (
-   -   Unable to access "FreeAgent Drive" on Fedora 19 (

S. Chapelin 10-10-2013 04:44 PM

Unable to access "FreeAgent Drive" on Fedora 19
I have just installed Fedora 19.
Of course I had made a backup of my precious data.
I put it on a Seagate 1 TB portable FreeAgent drive.
Unfortunately, I can't access the drive on Fedora 19.
Here is the message:


Unable to access "FreeAgent Drive"

Error mounting /dev/sdg1 at /run/media/Gilles/FreeAgent Drive: Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sdg1" "/run/media/Gilles/FreeAgent Drive"' exited with non-zero exit status 13: $MFTMirr does not match $MFT (record 0).
Failed to mount '/dev/sdg1': Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details.

The drive worked when I put my data on it in Ubuntu 10.4 and it still works on windoze 7 so I am thinking it must be a Fedora issue, maybe selinux caused.
What do you think?

S. Chapelin 10-10-2013 07:27 PM

I installed Ubuntu 12.04 and got the same problem and message.

S. Chapelin 10-10-2013 07:30 PM

I got this on ubuntu forum:

This is nearly always the result of simply disconnecting an External drive, one formatted as NTFS, without Safely Removing it first.

It is then marked as "dirty" and won't mount again in Linux until AFTER you hook this drive up to a Windows PC and run CHKDSK on it
I'm going to try it.

John VV 10-10-2013 07:42 PM


mount -t "ntfs" -o "uhelper........
that mount command is a bit wrong
Fedora uses "NTFS-3g" for the Microsoft NTFS drive format

also fedora and udev should AUTO mount it to /media/???????? something
as READ ONLY !!!! for non root users
there should be a auto created icon on the gnome desktop

at the very least in KDE's dolphin or Gnome's Nautilus in the left window under the files there will be a link to it
and there will also be a link in /media/???? some long number

if you want to bypass the udev created auto mount you need to add an entry to /etc/fstab
or wright a udev rule


fedora like RedHat START with root as user 500
and the first NON root user is 501

ubuntu uses 1000 and 1001

so the first non root user will have a guid of 501

S. Chapelin 10-10-2013 08:11 PM

I tried my drive in win7, then right clicked on it, chose properties, tools and hit the first button on top to check the disk.
Then I opened the drive in Ubuntu and it worked.
I am now copying my precious data on my hard drive.

All times are GMT -5. The time now is 03:04 AM.