-   Fedora (
-   -   udev fails to load on boot (

shafty023 10-02-2007 02:54 PM

udev fails to load on boot
Fedora 7 loaded w/

Okay so normally I don't reboot my desktop and when I finally got around to rebooting it, it hangs at "Starting UDEV". Never gets passed this point unless I CTRL+C it so that it can move on. There are other issues later on of course in the boot process that fail b/c of this.

Through echo statements I was able to see it is hanging inside of make_extra_nodes() in /sbin/start_udev. It never makes it out of there and I'm wondering if something prior to starting udev failed and causes udev to fail subsequently. I've tried a bare bones /etc/makedev.d/* with only core devices and no luck.

Ultimately I can use Ctrl+c through various lockups at boot and finally get to a console login where I can run /sbin/start_udev and it work perfectly fine. Then of course I can start X and get into my desktop. Just very annoying that it won't work by itself anymore.

As far as changes, I regularly yum update so I'm guessing some update happened to hose to my box. Any ideas?

angryfirelord 10-02-2007 03:33 PM

I've got all the updates installed with no issues. Did you change your repositories and install other things?

shafty023 10-02-2007 03:58 PM

I haven't changed any of my repositories besides adding livna. Haven't installed any software besides yum update lately either.

angryfirelord 10-03-2007 07:47 AM

Hmm, the only thing I can think of that would cause an issue is that the new kernel is having trouble with a piece of hardware.

Try booting Fedora with the option acpi=off.

shafty023 10-03-2007 09:10 AM

Well you're not going to believe this but I figured out what was causing this issue and it baffles me how it even caused this much problems.

I was experimenting around with ldap authentication for ssh and linux login. Well apparently udevd attempts to make a connection to the ldap server which is not ok seeing as how network connections haven't been established when udevd is being started. So what it was doing was trying to connect, then sleeping for 8 seconds, trying to connect, sleeping for 16, and on and on and on. It would never quit trying and would get stuck in a loop. This seems like a bug to me for people using ldap authentication. So I commented out the host and DN settings in ldap.conf and removed ldap from nsswitch.conf. Rebooted and whoala, works like a charm.

angryfirelord 10-04-2007 07:28 AM

Um, wow, I would've never though of that. :scratch: I'll have to keep that handy for reference. Glad to see it's working now!

All times are GMT -5. The time now is 07:13 AM.