-   Fedora (
-   -   tulip device eth0 does not seem to be present (

Toreal 03-07-2004 01:37 PM

tulip device eth0 does not seem to be present
I am getting very frustrated with my internett connection that used to work. I'm a newbee so it might be a stupid thing.

I have installed Fedora and it seems to work fine.

I believe that problem is connected to a message I get when I boot that says

"Bringing up interface tulip: tulip device eht0 does not seem to be present, delaying in itialization"

I have Compaq presario 1926 and I use a PCMCIA card :
D-link DFE-680TXD 10/100Mbit PCMCIA DirectPort.

Hope you can help!


edal 03-13-2004 06:52 AM

Similar Problem
Hi Toreal

I have a similar problem to you but slightly different hardware - same NIC but an Armada 1750. The problem is due to the startup scripts being executed in the wrong order, Fedora executes the network script before the PCMCIA script, so when the network script runs it cannot see the card (as there are no PCMCIA drivers loaded at this time). I have seen the problem with Red Hat 8, Red Hat 9 and now Fedora but nobody seems interested in fixing it. ARE YOU LISTENING RED HAT !!!

Things are not however as bad as they seem. When the PCMCIA drivers load they initialize all devices including the 680 NIC card, at which point your card should start working. Have a good long hard look at your network card settings and try pinging, if this works then the card should be OK.

Ed Almos
Budapest, Hungary

hooya27 04-11-2004 11:15 AM

For what its worth,

I just installed Fedora Core 2 test 2, and had the same message at boot. I think the tulip module is broken somehow. At any rate, to make my DE21041 card work, I had to remove the eth0 device in Network Configuration, then add a new device using the DE4x5 module. It came alive right away, and this is the first place I came after my internet started working (just like a good little member).

Don't know if it will survive a restart yet, but oh, well.

Happy Easter,

kernel version - 2.6.3-
Fedora Core 2 test 2

brandonarbini 10-06-2004 06:57 PM

Thanks a lot for the fix you posted. It worked like a charm for me as well. I'm installing Linux on a Compaq Presario 7360. I'm not sure what kind of ethernet card is in there, but your solution worked.

All times are GMT -5. The time now is 09:59 PM.