LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   System->Administration->Display window does not show up after installing kmod-nvidia (https://www.linuxquestions.org/questions/fedora-35/system-administration-display-window-does-not-show-up-after-installing-kmod-nvidia-726612/)

robogymnast 05-17-2009 02:25 PM

System->Administration->Display window does not show up after installing kmod-nvidia
 
I am attempting to get dual monitors working and I have made some progress but now am stuck.

First thing I did was `yum install kmod-nvidia` and reboot. After rebooting X did not start and I figured out the problem was my dual nvidia 6800's trying to use SLI. Alright, I don't need SLI so I took one out and now have just the one 6800, which has a DVI and VGA output. Now the system boots up and both monitors are working :-) but there are two issues:

One, as the title says is that going to System->Administration->Display has no effect. The system asks for the root pw and thats it, no display window comes up.

Secondly, my screens are on the wrong side: i.e. right and left screens are backwards. Can I fix this through my xorg.conf file? Here is what it looks like right now:
Code:

# Xorg configuration created by livna-config-display

Section "Files"
        ModulePath  "/usr/lib/xorg/modules/extensions/nvidia"
        ModulePath  "/usr/lib/xorg/modules"
EndSection

Section "ServerFlags"
        Option            "AIGLX" "on"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        Option            "Twinview"
        Option            "AddARGBGLXVisuals" "True"
EndSection

Section "Extensions"
        Option            "Composite" "Enable"
EndSection

Thanks,
Chris

archShade 05-17-2009 03:43 PM

to change the way twin veiw is round you need the line

Code:

Option          "TwinViewOrientation" "RightOf"
in the "Device section".

You shouldn't have to edit X.org in Fedora. have you tried running the nvidia graphical configuration program.

archShade 05-17-2009 03:44 PM

Oh if this does not work change "RightOf" to "LeftOf"

robogymnast 05-17-2009 08:17 PM

Quote:

Originally Posted by archShade (Post 3543926)
to change the way twin veiw is round you need the line

Code:

Option          "TwinViewOrientation" "RightOf"
in the "Device section".

You shouldn't have to edit X.org in Fedora. have you tried running the nvidia graphical configuration program.

Thanks Arch, I haven't used Fedora too much yet and this is the first time I've tried to set up dual screens, so I wasn't quite sure what the best way to do it was. I added that line to the xorg.conf file (it was "LeftOf" that worked) and it is working correctly now.

Does the fact that I installed the nvidia drivers supercede the gnome display screen? I wonder if that's why its not coming up?

Anyways, it's working well enough now that I'm happy =)

archShade 05-17-2009 08:42 PM

I'm speaking from somone who hasn't used fedora to much but while using ubuntu(with gnome) the nvidia driver installed an app called NVIDIA X server settings on system>>administration or launch from command line using nvidia-settings.

If I use the default Display configure I get warning message:
Code:

It appears that your graphics driver does not support the necessary extensions to use this tool.  Do you want to use your graphics driver vendor's tool instead?
So I assume that nvidia takes over completely.


All times are GMT -5. The time now is 03:21 AM.