-   Fedora (
-   -   Synaptics Touchpad / evdev Kernel 2.6.0-0.test9.1.87 (

fearofcarpet 11-16-2003 04:32 PM

Synaptics Touchpad / evdev Kernel 2.6.0-0.test9.1.87
I recently installed the 2.6 kernel in Fedora Core 1 on my Inspiron 600m and I configured the new Synaptics driver, which is working fine except for one thing... I guess this is more a generic linux question, but the "evdev" module has to load before X will start and apparently they way I have it loading (in /etc/rc.sysinit) it loads too late for the nice GUI Fedora Splash screen. So it tries to start the splash screen, but ends up falling back to the old text version. Once it processes rc.sysinit GDM fires up and I can log into KDE with no problem, but that friendly boot screen grew on me (even though I hated it at first) and now I want it back.

redjokerx 08-30-2004 01:38 AM

KDE has a SystemV start up editor. I'm not well versed in that style of startup (I'm used to BSD style you see). From what I understand though, you add a script or w/e in the /etc/rc.d/init.d/rc.5 and name it correctly. Is your evdev in modules.conf? If you're using the fedora bootup thing, you might be in framebuffer mode, and I'm not sure how well it'd work.

And since you have the same laptop as I do, and got synaptics to work (I'm assuming the side scroll works) can you tell me how to set it up? I've tried and failed.

fearofcarpet 08-30-2004 09:06 AM

I was only able to load the synaptics module which gave me nice smooth mousin' action. I could never figure out how to get the scrolling feature to work... I use a USB mouse 99% of the time though.

redjokerx 08-30-2004 08:28 PM

That sucks, the scrolling feature is what I was after.

Did that SysV thing work for you?

Yorthen 09-03-2004 09:38 AM

To get the synaptics-driver working first compile and install (duh!). Then edit your X-configuration-file (/etc/X11/xorg.conf for most
new dists) and add the following.

In the Modules section add Load "synaptics".

And add/edit your InputDevice section for the mouse to look something like this:

Section "InputDevice"
  Identifier "Mouse0"
  Driver "synaptics"
  Option "Protocol" "auto-dev"
  Option "Device" "/dev/input/mouse0"
  Option "CorePointer"
  Option "FingerLow" "25"
  Option "FingerHigh" "30"
  Option "MaxTapTime" "180"
  Option "MaxTapMove" "220"
  Option "VertScrollDelta" "100"
  Option "MaxSpeed" "0.12"
  Option "MinSpeed" "0.06"
  Option "AccelFactor" "0"

I'm not suer if the Option "Device" part does matter, I've gotten the same result whitchever device (mouse or event) that I've tried.

More information can be found in the INSTALL and README files which comes with the synaptics driver (at leas the sourcecode, don't know about rmps anc such).

redjokerx 09-03-2004 09:05 PM

I got synaptics to work on X, but I wanted the side scrolling feature. To tell you the truth, I'm not even sure if my dell has the synaptics touchpad. I was just hoping it'd work because Dell was on the list of supported laptops on the synaptics driver page. I just want the side scrolling to work

All times are GMT -5. The time now is 06:32 AM.