-   Fedora (
-   -   Superkaramba && Fedora core (

elnoxvie 06-18-2004 09:24 PM

Superkaramba && Fedora core
Anyone has successfully install superkaramba in Fedora Core 2 from source ?

I was having this error. During ./configure

checking for vsnprintf... yes
checking for snprintf... yes
checking for X... configure: error: Can't find X includes. Please check your installation and add the correct paths!

I suspect this is related with XFree that is being changed recently in FC 2.

ANyone knows how to fix this? The alternative that i heard is to use install XFree86-devel. But since compiling Superkaramba from rpm works(although karamba program always stay on top). I think there should be a way to fix this. If anyone knows the solution. Please post it here, So everyone knows :) .

Super karamba is a nice Program. I dun want to lose this. T_T.

Please help.


elnoxvie 06-19-2004 09:21 AM

I have solved it. The problem when installing karamba from source.

First missing X include can be solved by installing XFree86-devel

The second problem, missing qt can be solved by adding --with-wt-dir=/usr/lib/qt-3.3 in the configuration

./configure --with-qt-dir=/usr/lib/qt-3.3

The third problem missing KDE header can be solved by installing kdebase-devel


PS: Thanks for those people who are trying to help.

elnoxvie 06-19-2004 09:49 AM

Hi, The problem that i am having is more than that T_T. but i finish to solve it so in here, I would like to share it with you. If you do encounter these problems.

1st problem when doing make:

cannot find lselinux.

This can be done by making a symbolic link :

ln -s /lib/ /lib/

# This will solve the above problem.

The other problem would be missing lpng.

# To solve this, simply "apt" to get libpng-devel.

apt-get install libpng-devel


Benefit from community? why not thinking of giving back to community?

All times are GMT -5. The time now is 10:42 PM.