-   Fedora (
-   -   "Successful install" results in "Boot device not found" (

slackr007 05-31-2005 02:03 PM

"Successful install" results in "Boot device not found"
Ok, so I install FC2 yesterday and although it took me a while to get the IDE devices fixed up right(doesn't pertain to the problem, i don't think), I finally got it "installed successfully". So then I reboot to start linux for the first time and I get(after a long wait to get the IDE devices detected) a

That sounds to me like the MBR is messed up, but I don't know how to check that. I can still run the installer, repair, etc., but I don't know what do do with them. I had the installer set up the partitions automatically, but they looked kinda funny to me; though I don't know much about it. It made three partitions, instead of the two I expected. The first, hda, was the boot sector. The second, hdb was about 80% of the disk, of which I seem to remember seeing something to indicate that this was the system partition. Then the third, hdc, was just there. It was about the same size of hda, and didn't have a label, so I was unsure what it was supposed to be. There was previously a windows partition on this hard-drive, but I had the automatic partitioner delete it. The last bit of info that I can think of to tell you is what I got when I ran the repair thingy on the install disc and tried to do "startx". Here is the result:

Your system is mounted under the /mnt/sysimage directory.

When finished please exit from the shell and your system will reboot

sh-2.05b# startx
hostname: localhost.localdomain: Unknown host
xauth: creating new authority file //.Xauthority
xauth: creating new authority file //.Xauthority

Fatal server error:
Cannot open log file  "/var/log/Xorg.0.log"

Please consult the X.Org foundation support
        at http://wiki.X.Org
 for help.

giving up.
xinit: No such file or directory (errno 2): unable to connect to Xserver
xinit: No such process (erno 3): Server error.

I went to wiki.X.Org and found a thing about configuration problems here, but I tried to execute the xorgcfg in the prompt, but it just said "command not found".

I've still got it up and "running", so if there is anything you need me to do to get extra info, or whatever, just tell me. Any ideas on the problem anyone? Thanks for all the help in advance!

WhatsHisName 05-31-2005 07:02 PM

The message is just one of the many manifestations of a Grub problem.

Since you have a Knoppix disk, why not fix the problem using it? This type of grub problem is a really good reason to own a Knoppix disk (see ), because it can function as a high powered Linux Rescue disk. Here is how to proceed:

First, look at the Grub Manual ( ). It will be referenced below.

Boot using the Knoppix disk, open the KNOPPIX “Root Shell” and type:


which will (eventually) respond with the grub prompt:


Run the Grub commands “find ...”, “root ...” and “setup ...” as are described in the grub manual section entitled “Installing GRUB natively”. If you have a separate /boot partition, use “find /grub/stage1". Otherwise, use “find /boot/grub/stage1". If you get confused, just try both “find..” searches, since only one will give the correct location. There is also a section entitled “Installing GRUB using grub-install”, but the “native” installation gives you a lot more diagnostic information.

Assuming success, you should be able to exit Knoppix and boot into FC2.

But while you have Knoppix running, why not make a Grub Boot Floppy for future use (or a bootable USB flash drive). See the grub manual section entitled “Creating a GRUB boot floppy”. Using Knoppix 3.8.2, grub stage1 and stage2 can be found in /KNOPPIX/lib/grub/i386-pc/. You can boot using the floppy and quickly fix grub problems using the “find ...”, “root ...” and “setup ...” commands without booting into a Linux Rescue mode.

titanium_geek 06-21-2005 04:05 PM

WhatsHisName, this is an awesome guide to using knoppix to work with grub. Have you thought of posting it to the wiki? would you mind if I put it into the wiki, if you don't have the time?


All times are GMT -5. The time now is 07:48 PM.