-   Fedora (
-   -   Strange problem loading Anaconda (

bluetxxth 09-05-2007 02:08 PM

Strange problem loading Anaconda
Hi all,

First of all my system is going to be a fully dedicated Linux machine with a fedora core installed on it.

Here comes the prroblem:

I burn the ISO on Nero with the option ISO mode 1, so far so good. Upon entering the disk I perform the media check and it passes it. Most of the time there is no problem going trough the initial configuration steps. It loads the drivers in the order that follows:

1)ohci 1934
2)sata sil
3)a hci driver

The problem comes when anaconda starts loading, I get funny characters over a blue screen while loading Anaconda; these characters appear to me as colors represented in hexadecimal numbers. When this happens some times the installer exits abnormally and yet other times it allows me to move further on onto the installation. Sometimes the system stops responding at that point where the network configuration takes place; however some other times it progresses even further and then it stops right when it is getting the configuration files as if there was no media in the CDROM.

It seems to me that anaconda does not post anything strange on its log except the following:

<6> anaconda [759] general protection rip: 2aaaaad268d6 rsp:7fff9eaf5c50 error:0

I have tried the following distros:


All of these distros give me more or less the same errors

Aside of the graphic install I have tried numerous things such as typing at the shell the following commands:

linux text
I have also tried to reduce the memory to 256mb
Disactivating the processors Cache on the BIOS

As to for the hardware I have tested the memory with memtest and there were no errors found. Further testing was performed on the HDD and no errors were found either. The processor's temperature is 28C and the Chipset's temp. is 38C, quite normal.

Although I am new to linux I have been around computers for very many years and I don't understand how a simple installation could cause so much trouble. On the other hand I am starting to think that I may be overlooking a small detail and I am going crazy in trying to find out major issue. Will someone be so kind to help me please?

Thank you Bluetxxth

nomb 09-06-2007 10:15 AM

For Fedora 7 why don't you boot into a live cd and then install it to the hdd that way. See if you get the same errors, or any different ones for that matter.

There are disc for both kde and gnome so you can choose your destiny. :D

As far as installation goes from what you have, my first thought is going to be a hardware issue of some kind since it isn't erroring in the same place or with the same error. Try using the text installer instead of the graphical one and see if you get any different results. Or maybe it will let you see another error that is truly causing the problem. Just type 'linux text' at the 'boot:' prompt.

I'll keep pondering over this so let me know your developments.


bluetxxth 09-07-2007 07:22 AM

Hi Nomb,

Thank you for the answer, to be honest with you I have just started with the DVD installation because I don't have a CD of the size required by the live installations. I have downloaded all the files for the Fedora Core 7 and they are as follows

Fedora-7-KDE-Live-x86_64 / 831 MB

Fedora-7-Live-x86_64 / 779 MB

I only have 700MB available on my CD; I know this may be silly but is there something which I am doing wrong or should I just go and buy a 900MB CD?

Best regards,


nomb 09-07-2007 11:05 AM

If those are the torrents they might have extra files included in the torrent but the iso should fit on a standard cd. I don't have a 64bit machine so I haven't had to look at them before. All you can do is download them and try. :D

Let me know though, now im interested.


bluetxxth 09-12-2007 02:33 AM

Live image
Hi Nomb,

I am just about to try a new installation session, I ave 6 hours ahead in which I will try to fix the problem and eventually I will let you know. Let us see what happens.

However I would like to ask you if you think that the 386x files will work even if I have a 64x machine? The truth of the matter is that I have about 7 copies of different distributions.



bluetxxth 09-12-2007 04:40 AM

new install attempt
Hi Nomb,

I have just finished downloading the 386i live files and as soon as it starts loading I get a whole bunch of errors a few go like this:

unknown symbol journal....

modprobe fatal: error inserting ext3 (/lib/modules/2.6.21-1.3194.fc7/ext3.ko):

Unknown symbol in module or unknown parameter (see dmesg)

mount: unknown filesystem type ' ext3'
bug in initframs / init detected. Dropping to a shell. Good Luck!

bash: no job controll of this shell

some other times I get other errors which go like this:

Uncompressing linux...ok booting the kernel.

acpi invalid PBLK length 7
powernow-k8: mp systems not supported by psb bios structure....


I think that my machine does not like this versio, 386 that is...

What do you think? Now I am going to try to install it on a single athlon 64 single core possibly a venice core.



nomb 09-13-2007 09:46 AM

I had gotten those same errors on my laptop when I tried the live run. I never got it to work. I would think the 64bit processor could run the 32bit image but I may be wrong. Have you tried a 64bit image yet?


bibh_lnxq 09-15-2007 06:08 AM

In my experience using an install x-86 DVD, not x86-64, will not work at all, at least not with my machine (see my sig). I did not even get a message that all was wrong ;)

Booting x-86 Live CD's varies.

There may also be an issue if you burn Linux ISOs with Nero. It had something to do with Nero's adding some overhead which messed up the ISO image. I am sorry that I have to be so vague, but I cannot recall where I saw that info. If you have only a Windows platform at hand try burning with e.g. the freeware CDBurnerXP.

nomb 09-17-2007 10:18 AM

good advice, give that a shot blue.

bluetxxth 09-29-2007 10:14 AM

Problem Fixed
Hi B and Nomb,

thank you for the advice. Sorry I did not get back to the post earlier but the thing is that I have been overly busy. However I have fixed the problem by simply changing the main board. I had a DFI with an ATI chipset which is what is specified in my signature and in the end I changed it for an regular Asrock 939. The DFI was much better main board, however the Asrock does not give me problems at all.

Aside of this I also noticed that with the maxtor HDD I was using it gave me a format error. So I went and I changed the maxtor disk for a normal Seagate. In summary I did three things:

Changed ma inboard for a simpler one

Changed Maxtor disk for Seagate

All other remains the same.

The conclussion I drafted from this issue is that

1)the Maxtor either contained defective sectors or it was simply incompatible for whatever reason.

2) The Ati Chip RDX 3200 on the DFI ma inboard complicated everything further.

I am not sure I am 100% right but now my system runs 100% and I am very happy with it.

Thank you for the help and best regards,


All times are GMT -5. The time now is 08:39 AM.