-   Fedora (
-   -   Still Destroys Windows Partition? (

JSmith 01-06-2005 03:57 PM

Still Destroys Windows Partition?
Hey folks,

I remember when Fedora Core 2 first came out, everyone was reporting that installing it on a dual boot machine often destroyed the Windows partition. I later had heard that the bug was actually related to Kernel 2.6 and not Fedora.

Regardles...Is that bug still around? If I install the latest release of Fedora, is there any risk it'll destroy my Windows Partition (assuming no user error involved)?


bluesman2333 01-06-2005 07:54 PM

The partition was not actually destroyed. You just need to select LBA mode for your HDD's in the BIOS setup. Yes, it was a Kernal prob, but with at least SuSE and Mandrake, it is fixed with a new Ver. There are Kernal patches for the rest, AFAIK.

Belghouth 01-07-2005 01:10 AM

since Redhat 7, I have not distroy any of windows partitions. But (God loves me :rolleyes: ) I did not install FC2, but directly FC3. No harm with it.

adriaanbw 01-07-2005 06:58 AM

I have FC3 booting happily along side Windows XP both running on the same physical disk with GRUB in the MBR. In my opinion this is the best way to do it (with GRUB that is - feel free to use a different physical disk).

If you have issues, post back here!

defsy 01-07-2005 08:37 AM

as I am a new Linux user, I need help figuring something.
I had WindowsXP on my station at school and installed FedoraCore3 to make the station a dual-boot.
Everything was working fine before Christmas vacation but then I came back and Windows just won't load anymore. Because of that, I need to use another workstation to do quizzes and stuff....
Grub seems ok from what I can see...
Any idea how to get XP to boot again?
Thanks a lot in advance.

p.s. I tried rootnoverify, chainloader+1 and makeactive, at no avail.

Belghouth 01-07-2005 09:47 AM

Is there an entry for your windows partion in your /boot/grub/grub.conf ?
Didn't you distry your windows partition ?
What happens when you chose to boot Windows ?

defsy 01-08-2005 02:51 PM

thanks for the fast answer Belghouth.
There was an entry for my Windows partition but when I tried to load it, it gave me something about bad partition or something like that.
After trying a few things, the only thing left b4 formatting everything was to try loading my MS-Dos entry. Doing so led me to my Dos/WinXp boot loader. I tried to load XP from there and everything worked well. I deleted the WinXP entry in grub an I access everything now.
Thanks again though.

All times are GMT -5. The time now is 11:32 PM.