-   Fedora (
-   -   starting udev: problem (

math_1048 12-29-2006 07:47 AM

starting udev: problem
Hello my friends,
I install FC6 on my PC

Desktop PC

Motherboard: AWRDACPI - Gigabyte

Basic Input Output Systme(BIOS): Award Modular BIOS v6.00PG

Central Processing Unit(CPU): Intel(R) Celeron(R) CPU 1.70GHz

Physical Memory: 512MB

Hard Disk: SAMSUNG SP1604N (160GB)

Video Card: NVIDIA GeForce4 MX 440 DDR 64Mbyte

DVB Card: Twinhan, bt878

Monitor: ViewSonic E641-2

Audio Device: Realtek AC'97 Audio

Network Adapter: Local Area Connection - D-Link DFE-530TX PCI Fast Ethernet Adapter (rev.C) (Connected)

Keyboard: Standard 101/102-Key or Microsoft Natural PS/2 Keyboard

Mouse: USB Human Interface Device

but th OS freeze at starting udev:
I do search about this problem in forum; I understand that this problem related with PCMCIA - but I dont have this module (not exist in my pc):Pengy:
thank you very much.

blackhole54 12-30-2006 02:47 AM

Why do you say the udev problem is related to PCMCIA? And what module don't you have on your computer and why is it relevant? I'm just trying to understand what is going on here.

jschiwal 12-30-2006 03:48 AM

Read through your boot log for any other clues. One thing that can help with booting sometimes is to use the "noapic" boot option. Another thing I wonder is if the dbus daemon is running.

math_1048 12-30-2006 01:15 PM

Sorry Dear may I dont describe the problem well, that bcoz Iam new in Linux:)

Originally Posted by blackhole54
Why do you say the udev problem is related to PCMCIA?

When I search for problem I found article like this

Originally Posted by blackhole54
And what module don't you have on your computer

I mean my computer is Desktop one and no PCMCIA module(socket) are existing in it

Originally Posted by blackhole54
and why is it relevant?

Dear I understand that the problem are PCMCIA problem !!
from the above Urls, sorry if I :confused: dont get it.

Dear jschiwal How can I know that dbus daemon are running?
sorry dear Iam :newbie: at Linux.:)

thank you very much

blackhole54 12-30-2006 08:08 PM

I suggest you try to boot your computer in single user mode (runlevel 1 or S). I am sorry, I am not familiar with FC or terribly familiar with GRUB, so you might need to google for how to do this. Under LILO (rather than GRUB) you would just enter the following on the boot line:

linux 1

If you can successfully boot into single user mode, try disabling PCMCIA for runlevel 5. Again I hesitate to give you advice on how to do this since I have not used FC. If nobody posts how to do this, and if you are successful booting into single user mode, I will try to give you some more guidance.

jschiwal 12-31-2006 03:09 AM

There may be a safe mode option that you can try as well. It will use a number of kernel options. This mode will boot up very slowly, as it disables dma as well. Some devices may not work with the "noacpi" option it uses, because acpi may be used to set up the irq numbers, and on modern mobos you will have irq's shared.

If the safe mode does boot up, you can delete one of the boot options at a time until you are left with the option that allows booting to continue.

I mentioned the "noapic" option because it is the option I used that allowed me to upgrade my desktop. Otherwise, the boot kernel wouldn't run. Most of the time it won't hurt unless you have an Opteron multiprocessor system.

What did the boot log indicate. Which services were started but not finished?

math_1048 12-31-2006 05:52 PM

Thank you, Thank you, Thank you very much my friends for help,
I try that to enter at level 1 by using rescue and do rename the /sbin/pcmcia-socket-startup or failsafe with changing options put no change, but I understand from U that , its HW problem so I unplugged my bt878 device and all gone OK:)
but I really need to use it under my Linux ,so dears I found this article to make kernel support for DVB cards
make menuconfig //for selected new modules
make //but when I use make command its give me 2 errors.
and cant complete the precess.
thank you very much my friends for help.

jschiwal 01-01-2007 12:26 AM

I meant selecting a safe option in the boot menu. You can manually edit the options you use to boot in the grub shell. I don't mean changing any filenames or editing files. But if the safemode doesn't work, then the option of narrowing down which option it took is moot.

You might try posting your boot log. I'm not convinced it has anything to to with the pcmcia module.
This howto explains what the boot options mean:

On a running system, you could run:
/sbin/chkconfig | grep dbus
dbus on
to check if the dbus service were running ( unless you use slackware or bsd which handles services differently ).

However, since you can't boot up, you will need to read what the boot log says.

I should backup a bit. Sometimes a stall in booting can be solved by unconnecting unneccesary external devices. I have has an occasional stall that unplugging an external USB device solves. This problem only rarely happens for me however. It may have something to do with the external device as well in my case.

math_1048 01-01-2007 07:15 PM

Dear jschiwal
I use The `pci=noacpi' Argument && The `acpi=off' Argument, but the result is the same,
then try to boot with all options avaliable in the bootloader options, but also the same result, its hanging at starting udev:
Dear I cant running my system normally I must enter my system with rescue cd
or unplugged my bt878 device,
so I install Redhat Linux dis. (but before reading your last topic about running /sbin/chkconfig | grep dbus
dbus on for give us more info about the problem ). I was have it before:)
and its work very well,
Thank you very much my friend jschiwal , but I have Question is that
I see FC6 and Suse 10.1 Dis. have many new and wonderfull software packages are there an Application Can make like installation manager ,
mean that its can read the package from FC6 and Suse 10.1 DVDs for example and orders them packages to allow us to install it onto the current Linux dis we used :Pengy:
Thank you very much

jschiwal 01-01-2007 09:29 PM

If a particular device such as the bt878 card is causing the problem, then look in the Boot Prompt Howto I earlier supplied a link to. It has instructions on the reserve boot option, to keep the kernel from probing the device when you boot up. I think that the kernel probing the memory area that the device uses is what is causing the problem. The "man modprobe" and "man modprobe.conf" have information on how to effect the load order of kernel modules, if that is the problem, instead. Is the bt878 device on a pci card or a removeable pcmcia card?

When I suggested posting the boot logs, what I meant, is that after it stalls, boot up with the rescue disk, mount your regular filesystem and access the boot log from when you tried to boot normally.

I think that you may need certain module options for the bt8xx kernel module.
The kernel source documentation "dvb/bt8xx.txt" lists different modprobe options for different products. Also make sure the bt8xx and tuner modules are modprobed. You may need to install your kernel source and a kernel-docs package as well to access this text file. For information on filesystems and modules, the more exact information may be included in the kernel documentation.

There is a BT8x8.pdf howto document, but I don't know where I got it from. Maybe the website.

math_1048 01-02-2007 01:36 AM

Thank you very much Dear
I found a good tutorials about Bttv at
Thank you for this website,I reinstall FC6 and Will try with the new instructions,and will do my best:study:
Do you know about an Application/way to collect information about packages in DVDs of another Linux Distributions:Pengy:
That bcoz I need to Import some wonderful Apps from Suse:) to my another distribution:Pengy:
Thank you very much

jschiwal 01-02-2007 03:59 AM

You could probably be able to find the same package for Fedora Core as are available for SuSE.
If you downloaded an rpm, you can use the command: "rpm -qip <filename>" to read information on the package.
"rpm -qlp <filename>" will list the contents.

A package installed for another distro may not show up in the kde menu for example. The scripts that set it up may be distro specific.

Another option is installing from a source tarball. You can also install a source rpm and use rpmbuild to build a package. This allows tweaks during the compiling process. I will do this to access the .texi documentation and use "make pdf" or "make pdfdocs" to generate printable versions of the docs.

math_1048 01-02-2007 06:19 PM

Thank you very much my friend jschiwal
will try using this CMDs, I found this CMD
but I think its will not be good with DVDs bcoz I detect that apt are search for special index
thank you very much

All times are GMT -5. The time now is 05:39 AM.