-   Fedora (
-   -   ssh timing out after Fedora 13 to Fedora 14 upgrade (

RichyAD 05-19-2011 05:33 PM

ssh timing out after Fedora 13 to Fedora 14 upgrade
A few weeks ago I upgraded one of my laptop from Fedora 13 to Fedora 14 (using pre-upgrade). The upgrade went smoothly and no errors appeared. However ever since the upgrade ssh is not working anymore. I've tried various servers inside and outside the local network. I can't contact any of them. In all cases I get:

ssh: connect to host aaa.bbb.ccc port 22: Connection timed out
I've tried to get more info using the -vvv option form ssh, but it doesn't mean too much to me:

OpenSSH_5.5p1, OpenSSL 1.0.0d-fips 8 Feb 2011
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to aaa.bbb.ccc [] port 22.
debug1: connect to address port 22: Connection timed out
ssh: connect to host aaa.bbb.ccc port 22: Connection timed out

Actions so far:
- checked internet connection. No problem there. Another laptop is working fine using the same connection and the same ethernet cable. That laptop is still using Fedora 13, since I didn't want to get stuck without ssh completely.
- checked "messages" log. No messages at the time of ssh connect attempt.
- checked "secure" log. No messages at the time of ssh connect attempt.
- checked the firewall settings. The settings are exactly the same as before the upgrade (when ssh was still working). Moreover, the settings are the same as the other laptop that is working.
- temporarely switched off the firewall. No difference.
- temporarely switched off selinux. No difference.

So it doesn't seem to be a firewall or selinux problem. And I know the connection is working, so it does not seem to be a routing problem either. What am I missing here?

System specs:
- Asus EEE PC (1 GB RAM, intel atom processor);
- Fully up-to-date Fedora 14 (kernel

Let me know what else you need and I'll post it.


John VV 05-20-2011 04:51 PM

i bet you did not remove orphan fedora 13 rpms ( ones that are NOT in 14 )

14 removed a few and replaced other programs with different ones

install yum-utility and run the remove orphans option

man yum-utility
search yum for the correct spelling ( in case i misspelled it's name )
" yum search yum "

RichyAD 05-20-2011 07:57 PM

Nope, didn't forget that. It was the first time I used preupgrade, so I dutifully followed the steps on wiki page (

I did get some .rpmsave and .rpmnew files. The only ones of note maybe are sssd.conf and ldap.conf. But I checked them and I couldn't find anything wrong with them. Could these have anything to do with this?

John VV 05-20-2011 08:14 PM

".rpmsave and .rpmnew files"
most likely not a problem
These just allow you to back out of settings changes or reset the new files with the values saved in the rpmsave file

check the new config files against and rpmsave back ups to see if there are different

one thing that might cause problems in the settings in files in the ~ folder (/home/YourUserName or /root )

for something like ssh ?
go through and reset everything .Something did not upgrade right .It happens , that is why i always did fresh installs with fedora .

RichyAD 05-20-2011 09:18 PM

Already had a look at the .ssh folder and cleaned the knownhosts file.

But the problem seems to be system-wide. I've tried ssh from two used accounts and as root. All suffer the time-out. I've checked the /etc/ssh/sshconfig against my other Fedora 13 version and they're the same.

I think I can force a re-install of ssh from yum. Maybe that'll help ... I really don't want to go through a fresh install just to get ssh up and running. That feel so windows-like.

Capitan Planeta 05-21-2011 12:07 AM

Have you checked that the service is running?

Try (on the machine you are trying to access):

$ service sshd status

and see if it is.

RichyAD 05-21-2011 06:44 AM

@Capitan Planeta

On this Fedora 14 laptop I don't have the ssh deamon (sshd) running. This is not necessary. I only want to use the ssh client (ssh) to connect to a server. And that's timing out.

Obviously on the servers that I'm trying to connect to the ssh deamon (sshd) needs to be running. Since I can connect to these servers from my other (Fedora 13) laptop, this is not an issue.

By the way, I'm administrator of one of the servers that I'm trying to use. I've checked the logs on that machine and there are no entries about my connect attempts. It is safe to assume that the connection on Fedora 14 laptop fails before it reaches the server. Hence the "time out" error.

@John VV

I'm going to try and force a reinstall of the ssh client later today. Let see what happens.

RichyAD 05-21-2011 09:10 AM

The problem seems to have "solved" itself. But I have no clue what happened ...

I reinstalled (open)ssh, but I still got a connection time out.

It did occur to me (only now) to check where the connection was timing out. So I used traceroute and something interesting popped up. When tracing the route on the functioning (Fedora 13) laptop, I got:

> traceroute -T -p 22 aaa.bbb.ccc
traceroute to aaa.bbb.ccc (, 30 hops max, 60 byte packets
 1  ddd.eee.fff (  0.182 ms  0.128 ms  0.197 ms
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14 (  31.995 ms  33.382 ms  41.693 ms

So the packet seems to reach the server. Using the same connection (i.e. same cable), the Fedora 14 laptop gave me:

> traceroute -T -p 22 aaa.bbb.ccc
traceroute to aaa.bbb.ccc (, 30 hops max, 60 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

So the maximum number of hops was reached before getting to the server. In additon, there was no response from the first (local network) router/gateway. I checked the /etc/resolv.conf on both laptops and they were identical. Also I got the same result with and without firewall and selinux on.

Just out off curiosity I decided to hook up my mobile phone and check the route through my mobile internet connection. And what do you? The connection route reached the server!! I tried the ssh connection and it worked through the wireless mobile connection.

But the strangest thing of all: after I disconnected from the mobile connection, I plugged in the cable and tried traceroute and ssh again ... And now it works! I'm completely baffeled. Something must have been reset when I used the wireless connection. I just don't know what ...

I'm glad the connection now works, but I would prefer to understand the root of the problem. So if anybody has any clues, please let me know. It may help people with similar problems.

All times are GMT -5. The time now is 11:13 PM.