LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 02-07-2004, 06:13 PM   #1
Forezt
Member
 
Registered: Jun 2003
Location: Aero-nomadic
Distribution: Debian (etch, PPC)
Posts: 80

Rep: Reputation: 15
Soundcard works sometimes, not all the time


I thought i got my integrated 82801DB AC'97 Audio Controller (module: i810_audio) installed and working with ALSA. I rebooted after the install, and sound was working perfectly.

I just now got into Linux, a night later, and sound isn't working at all. I have no idea what the problem could be, I went through all of the steps necessary. I installed all of the ALSA rpms I needed and did modprobe for my module.

When I type in alsamixer into the terminal, I get this message:

Code:
alsamixer: function snd_ctl_open failed for default: No such device
I have not tried alsactl to save my settings. Would that have anything to do with it? If so, how do I get it working again so I can save the correct state?
 
Old 02-07-2004, 07:50 PM   #2
deloptes
Member
 
Registered: Feb 2004
Location: AT
Distribution: debian etch and SUSE 10.2
Posts: 123

Rep: Reputation: 15
It was a little bit fuzzy but I used a good howtos from google.

you disable your sounddriver in the kernel and let sound configured as module

build kernel and modules and install.

then build alsa-driver, afterwards alsa-lib and utils

I downloaded also the alsaplayer and put everything under /opt/alsa.

No I just miss a gtk-mixer

What was important to do is run after installation from the shell following lines - that actually unmuted the alsa-driver
# amixer set Master 100 unmute
# amixer set PCM 100 unmute
# amixer

starting alsamixer didn't unmute

now after this I added some stuff like this below in /etc/modules.conf (Oh, my god, debians conf area! Don't warry it worked!)
I got the output from another program called alsaconf (you find it under $PREFIX/sbin)
If you have devfs (i.e. distros like mandrake and redhat use it as far as I know), then there are different files to modify, consult the docs.

#
## ALSA portion
alias snd-card-0 snd-emu10k1
## If you have more than one, add:
## alias snd-card-1 snd-intel8x0
## alias snd-card-2 snd-ens1370
## OSS/Free portion
## alias sound-slot-0 snd-card-0
## alias sound-slot-1 snd-card-1
##

I think it's better to start experimenting with kernel higher than 2.5 as alsa can be compiled from within the kernel

Hope I could help
 
Old 02-07-2004, 10:30 PM   #3
Forezt
Member
 
Registered: Jun 2003
Location: Aero-nomadic
Distribution: Debian (etch, PPC)
Posts: 80

Original Poster
Rep: Reputation: 15
Quote:
you disable your sounddriver in the kernel and let sound configured as module
How do I do that?

 
Old 02-08-2004, 07:33 PM   #4
deloptes
Member
 
Registered: Feb 2004
Location: AT
Distribution: debian etch and SUSE 10.2
Posts: 123

Rep: Reputation: 15
jezus guys, what do you have the www for ?
all you need is read and google is also there
I posted a very brief how to
read the docs from the alsa web site
http://80.110.253.135/~deloptes/linu...ort_2.4.X.html
 
Old 02-09-2004, 05:51 PM   #5
Forezt
Member
 
Registered: Jun 2003
Location: Aero-nomadic
Distribution: Debian (etch, PPC)
Posts: 80

Original Poster
Rep: Reputation: 15
Ok, I went to disable my sound drivers using this method as described the that guide and ran into a little problem:

First of all, here is the guide to remove or diable the sound drivers:
Code:
# cd /usr/src/linux 

# cp .config / 

# make mrproper 

# cp /.config . 

# make menuconfig
I got this output when I foloowed the first two steps:

Code:
[root@localhost root]# cd /usr/src/linux-2.4.22-1.2149.nptl
[root@localhost linux-2.4.22-1.2149.nptl]# cp .config /
cp: cannot stat `.config': No such file or directory
What am I supposed to do? I guess I don't have that .config file. Is it a different name in my kernel?

 
Old 02-10-2004, 05:40 PM   #6
deloptes
Member
 
Registered: Feb 2004
Location: AT
Distribution: debian etch and SUSE 10.2
Posts: 123

Rep: Reputation: 15
This is very brief what I wrote, relaying on it would afford a lot of imagination.
Read more about the kernel, cause it means you've never build a kernel (at least in this directory) before.
So skip this and fire make xconfig (I hope you're using the X server)

On some distros the make script finds the configuration of the kernel you are using at the moment, its usualy in /boot

you can copy this file for sure in the kernel directory

i.e.

cp /boot/config-2.4.24-EMO /usr/src/linux/.config

and

make xconfig

so now follow my instructions, but read more about building and installing a kernel. I don't have time to write all the stuff, as it has been already written.





r3gards
 
Old 02-14-2004, 06:13 PM   #7
Forezt
Member
 
Registered: Jun 2003
Location: Aero-nomadic
Distribution: Debian (etch, PPC)
Posts: 80

Original Poster
Rep: Reputation: 15
Ok, I just got a book about Linux, and read the section about modules and I think I get it now. I have one question, though. How can I tell if my sound is controlled in the kernel? I think that it is controlled by modules right now. Here's my lsmod:

Code:
Module                  Size  Used by    Not tainted
i810_audio             27560   2  (autoclean)
ac97_codec             16712   0  (autoclean) [i810_audio]
lp                      8580   0  (autoclean)
parport                37056   0  (autoclean) [lp]
autofs                 12084   0  (autoclean) (unused)
8139too                16200   1
mii                     3992   0  [8139too]
ipt_REJECT              4216   1  (autoclean)
ipt_state               1080   1  (autoclean)
ip_conntrack           28136   1  (autoclean) [ipt_state]
iptable_filter          2444   1  (autoclean)
ip_tables              15008   3  [ipt_REJECT ipt_state iptable_filter]
floppy                 57308   0  (autoclean)
sg                     35436   0  (autoclean)
sr_mod                 17400   0  (autoclean)
microcode               4188   0  (autoclean)
audio                  46296   0  (unused)
soundcore               6468   2  [i810_audio audio]
ide-scsi               12016   0
scsi_mod              110280   3  [sg sr_mod ide-scsi]
ide-cd                 34432   0
cdrom                  34592   0  [sr_mod ide-cd]
ohci1394               28776   0  (unused)
ieee1394              203940   0  [ohci1394]
nls_iso8859-1           3516   1  (autoclean)
nls_cp437               5148   1  (autoclean)
vfat                   12524   1  (autoclean)
fat                    38040   0  (autoclean) [vfat]
keybdev                 2656   0  (unused)
hid                    23908   0  (unused)
ehci-hcd               20008   0  (unused)
usb-uhci               26124   0  (unused)
usbcore                78752   1  [audio hid ehci-hcd usb-uhci]
mousedev                5268   1  (autoclean)
input                   5888   0  (autoclean) [keybdev hid mousedev]
ext3                   71716   2
jbd                    51276   2  [ext3]
So should I just rmmod ac97_codec , i810_audio, audio, and soundcore?
 
Old 02-23-2004, 04:55 PM   #8
Forezt
Member
 
Registered: Jun 2003
Location: Aero-nomadic
Distribution: Debian (etch, PPC)
Posts: 80

Original Poster
Rep: Reputation: 15
hello? Did you die?
 
Old 03-02-2004, 08:18 PM   #9
deloptes
Member
 
Registered: Feb 2004
Location: AT
Distribution: debian etch and SUSE 10.2
Posts: 123

Rep: Reputation: 15
Unhappy

Hi,
I think I was in some kind of coma, I did die! I am single again, I moved, spent a week in munich, got 31 and have to work 10hours a day :~# in the next 2months

what would you say - I yould say cheers!

I have now new ip for all of you wanting to read this alsa stuff

http://213.47.57.130/

a redirect under http://deloptes.t2u.com does it right too



Now about your question

The sound card IS controlled by the module and the module IS part of the kernel (at least becomes after you load it - think as of piece of puzzle ).

There is a lot of information on the net and a discussion why ALSA is better than OSS and vice-versa.

For me - I made my choice ALSA!

if removing the modules and inserting the alsa once doesn't help, disable the automatic load of the modules at boot time and replace them with the alsa once.
I did it and it worked after I rebooted - you have to reboot anyway to use the new kernel, but afterwords you can do this and experiment.

r3gard5
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Soundcard works only after auto detection in FC3 bmeagle Linux - Hardware 3 01-12-2005 08:56 AM
no signal when starting xorg for the 1st time (but the second time works fine) bungalowbill Linux - Software 0 06-04-2004 09:56 AM
aureal vortex2 soundcard works in md10 rrsc16954 Linux - Hardware 0 04-07-2004 06:44 PM
aureal vortex2 soundcard works in md10 rrsc16954 Mandriva 0 04-07-2004 06:32 PM
Sis 7018 onboard soundcard problem, works in RH9 but not in MDK9.1 SentinelT Linux - Hardware 2 11-24-2003 06:57 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 08:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration