LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   sound card won't work - Cirrus Logic CS 4614/22/24 (https://www.linuxquestions.org/questions/fedora-35/sound-card-wont-work-cirrus-logic-cs-4614-22-24-a-386373/)

MissLioness 11-25-2005 07:15 AM

sound card won't work - Cirrus Logic CS 4614/22/24
 
I have an IBM A20m 2628-21U with 128MB Ram and a 6GB Harddrive. I just installed Fedora Core 4 (used Personal Desktop Package Option) and no firewall or security. It installed until it got to the hardware-- It was checking the sound, and said I should hear three sounds.... I didn't, and clicked the button that indicates such. Was then displayed a message that said that audio would not be available on this system (or something similar)

The sound card on the device list is Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio Accelerator] The device information listed is Manufacturer: Unknown, and Driver: snd-cs46xx


I installed Linux so I could play music and movies.... I'm at a loss as to what to do now. This is my first experience with Linux, and am a little frustrated right now.

Do I need a differnt driver? or is there something that can be done?
Thanks

Gethyn 11-25-2005 08:04 AM

It seems that there is support out there, the following pages (one) (two) suggest that other people have got the card working.

Ask the silly question first: did you have the sound on the laptop turned up? Try re-running Soundcard Detection (it's on the main menu, under System Settings in KDE, not sure about Gnome), and checking your ALSA volume levels. If I remember rightly, some distros had the volume on mute by default. This isn't the case with FC4 as far as I know, but it may have been set too low to come out...

MissLioness 11-25-2005 12:10 PM

Thanks... I did try the volume... Actually, on the laptop, there are three buttons.. increase volume, decrease volume and an on/off audio button. I tried re-running the Soundcard detection several times to see if made any difference. Nope... still no sound. Here's another thing... before I put Linux on the machine---and was running windows NT, when I pushed one of those volume buttons, I would see either volume level indicator, or a mute/not mute indicator on the screen... Now, nothing. I do know the sound does work because the BOIS setting for low battery alarm is set, and last night, that alarm went off (didn't have it plugged in!)

Still no luck...

heffo_j 11-26-2005 04:10 PM

Miss Lioness,

My comment won't fix your problem but I am posting it because I think it might be a FC4 issue. My sound card is not detected either. Mine is an intel based chip on my card. It has been detected by ever other distro that I have tried: Knoppix, Mepis 3.3, Suse 10, Ubuntu, Kanotix. It seems amazing that Fedora hasn't got it right. To be honest, I think it slipped through their testing processes.

My 2 cents worth - best of luck.

John

Lnx805 11-27-2005 12:00 AM

Miss L,
This is a common issue with FC4. In fact if you run a search in this forum you'll find there's been a lot of discussion about this topic.
Anyway, if you're using KDE, run kmix, show mixer window and go to the "switches" tab. Enable "external amp", this should turn on the sound. Don't close the mixer window, instead right-click on the speaker icon [sys tray] and select hide mixer, [this will keep it active].
Another method is to run alsamixer in a terminal window. Again, enabling the external amp should turn on the sound.

heffo_j 11-27-2005 04:39 AM

G'day Lnx805,

I ran the alsamixer in root but I could not "alsactl store" to work. I got the good old "command not found" response.

Any clues? The sound card still won't work even though every other distro I have used it hac not been an issue.

Regards
John

Lnx805 11-27-2005 07:11 PM

Hi John,
I'm not sure what you're referring to, ["alsactl store"][?]. And, I don't need to be root to use alsamixer. I just bring it up in terminal and when I'm done, press escape and the settings are saved. I forgot to mention before to press "tab" to toggle over to "All", press "M" to enable [or disable] a selected vol. slider and the up & down arrow to set the volume.

Which gui are you using KDE or gnome? In KDE control center --> sound & multimedia --> sound sytem --> general - "sound enable". And under the "hardware" tab the sound is set to autodetect. Then try the "Test Sound". If you have kmix running make sure the volume is turned up, [most of the adjustment is in the top 4th of the scale]. Kmix is the gui version of alsamixer.
If don't still don't hear anything, log in as root and run lsmod [module listing] and lspci [check if the card is detected].

HTH
Pete

rchiicz 12-05-2005 10:56 PM

Hey, all. I have the Cirrus Logic 4614 on a an old "eMachines eTower 500" and could get no sound out of it (but system-config-soundcard did detect the right chipset).

Similar to what Lnx805 said with enable of "external amp", I found a post on on redhat email list archives that FIXED IT FOR ME!

on the: redhat archive site: november 2005, msg # 02131

the idea is to enable the "DAC" volume slider (hidden by default), and crank the volume up on that thing.

Like magic.

------ snippet from redhat posting ---

On Sat, 2005-11-12 at 12:33 -0600, Gregory P. Ennis wrote:
> Everyone,
>
> I have a couple of E-Machine new installs of FC4 and have had some
> difficulty getting this sound card (Cirrus (Logic CS 4614/22/24) Sound
> Chip) to work. The card is recognized by the sound detection software
> but does not seem to be controllable by any of the software I have
> found.

I have a CS 46xx sound device in my T20

Applications -> Sound & Video -> Volume Control

>From that app -

Edit menu, choose preferences

click on the DAC checkbox so that the DAC mixer will be shown.
Then in the Capture tab - turn up the DAC mixer.

That's what worked for me.

heffo_j 12-06-2005 02:35 AM

Follow up:

Sound car works with CentOS. I can't work out how to get the external amp to swith on from the Terminal "alsamixer".

John

djhaskin987 12-10-2005 12:36 PM

same blasted thing
 
i have the exact same problem with the exact same sound card, except my laptop is an IBM (lenovo) T20-2647 type 41U (essenitaly the same thing.), with FC4 on it. it correctly id's what card, and sais the module's snd-cs46xx. what does that mean? and also, i know there are drivers out there for linux, because i installed mandrake 10 on here previously and it ran good. where can i find drivers that work with FC4?

djhaskin987 12-10-2005 12:39 PM

same blasted thing
 
i had the same thing. ibm T20, Cirrus sound card, DAC crank up and fixed it. i love you, man. :D

Lnx805 12-10-2005 02:23 PM

Quote:

Originally Posted by heffo_j
Follow up:

Sound car works with CentOS. I can't work out how to get the external amp to swith on from the Terminal "alsamixer".

John

To toggle any slider in alsamixer, just press "M". Adjust volume with the up & down arrows and to select a slider use the left or right arrow. To change modes use the tab and to quit press "esc".

HTH
Pete

heffo_j 12-10-2005 04:13 PM

Thansk Pete, all okay now.

John

Dimension User 12-29-2005 09:23 PM

Quote:

if you're using KDE, run kmix, show mixer window and go to the "switches" tab. Enable "external amp", this should turn on the sound. Don't close the mixer window, instead right-click on the speaker icon [sys tray] and select hide mixer, [this will keep it active].
Thank you so much for your help, Lnx805! I have a new Toshiba M30X and I thought it was going to be a lot more work to get the sound working. I just enabled the external amp like you said, and sound works perfectly. Why couldn't FC4 do that in the first place? Thanks again for your help!

tzavaleta 02-16-2006 07:51 PM

fixed sound on my t20
 
I was tried adjusting all the mixer settings and I still couldn't get anything to work with my Thinkpad T20 and FC4.

Finally I landed on ALSA website and completed their driver install with the latest version. This is a link to the instructions for this specific card:

Well i can't post the link since i haven't posted 5 messages. But you can go there, select the card matrix and select this card. Instructions are clear from there.


Now I have sound!! I hope this helps someone.


All times are GMT -5. The time now is 01:52 AM.