LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 04-09-2005, 03:49 PM   #16
xzallion
LQ Newbie
 
Registered: Apr 2005
Posts: 17

Original Poster
Rep: Reputation: 0

Maybe I need to install new ALSA drivers?
 
Old 04-09-2005, 09:06 PM   #17
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
xzallion: Haven’t forgotten about you, but it’s the weekend, so my response time will be slow.

The lack of error messages makes me think that the sound module is properly installed.

FC3 already uses the ALSA drivers you see on the web site. It is remotely possible that something was corrupted during the FC3 installation, but not really likely. If you run out of things to try, it won’t hurt anything to download the drivers and go through the installation as described on the web site, but I would think about just reinstalling FC3 before doing it.

Here are a few more thoughts and things to try:

1) Try playing a sound from the sound preferences to rule out setup problems with the CD or some other oddball hardware problem, but first go through and recheck all of the sound settings.

Go to the Volume Control (Redhat > Sound & Video > Volume Control) and verify that everything is unmuted and all volume control sliders are at the top (maxed out).

Then go to the sound preferences (Redhat > Preferences > Sound) and verify that both boxes are checked in the General tab (i.e., Enable Sound... and Sound for Events).

Then switch to the Sound Event tab and scroll down the list until you find a few listings in the Sound File column and try to play a few of them. If still no sound, go to steps 2 and 3 below.

2) Post the contents of /etc/modprobe.conf. Maybe something obvious will jump out at someone.

3) If you are using a custom built system, list the motherboard manufacturer and model number. If it is a commercially built system (e.g, Dell, Gateway, HP, etc.), then what is the manufacturer and model number. If you have a web address that gives the specifications for either the motherboard or the system, it would be helpful.
 
Old 04-10-2005, 12:34 AM   #18
xzallion
LQ Newbie
 
Registered: Apr 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Ok, I have reinstalled, and no sound. I am going to go through and check everything you said in the above post WhatsHisName. I will Edit this entry later when I get the chance.

Edit:
[root@localhost ~]# /etc/modprobe.conf.
bash: /etc/modprobe.conf.: No such file or directory
[root@localhost ~]#

I think somethings is wrong if it cant find the file...and I just reinstalled it args.

I am using a Dell Dimension 2400 with 512mb ram and a nvidia card, and its all standard stuff from there.

Last edited by xzallion; 04-10-2005 at 12:41 AM.
 
Old 04-10-2005, 10:00 AM   #19
mjmwired
Member
 
Registered: Apr 2004
Distribution: CentOS6, CentOS5, F16, F15, Ubuntu, OpenSuse
Posts: 620

Rep: Reputation: 39
Are you sure it is not there? Did you look in the /etc/ directory?

# ls -la /etc/modprobe.conf
# cat /etc/modprobe.conf
 
Old 04-10-2005, 12:09 PM   #20
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
xzallion: Looking at the Dell specs was interesting (specs: http://www1.us.dell.com/content/prod...pecstab#tabtop). What you are probably using as a sound chip is an “Analog Devices ADI 198x Integrated Audio”, which is an “Integrated 5.1 Audio with Dolby® Digital 5.1 capability” (see WinXP drivers at http://support.dell.com/support/down...&os=WW1&osl=EN).

That really sheds a lot of light on your problem. It sounds like your motherboard has a VIA Technologies-based South Bridge. I suspect that you will need to install an additional driver to get the sound to work.

My first suggestion is to repeat the sound tests (and any future tests) using a headset plugged into the front of the box, in addition to your speakers. Just like trying to play the sound files, the headset will provide the most basic way to “hear” the sound you are trying to play.

Now look at the ALSA driver page for the sound chip (http://www.alsa-project.org/alsa-doc...Devices#matrix). For the AD 198..., there are two drivers listed, the intel8x0 and the via82xx (see via82xx at http://www.alsa-project.org/alsa-doc...module=via82xx). I am fairly sure that one system I have at work uses this same driver pair, but I will need to look in modprobe.conf to be sure.

The intel8x0 module is already installed (unless we messed something up), so what you need to do is to install the via82xx module. Because the ALSA drivers are already part of FC3, all you should need to do is to follow the steps from the ALSA page. From the terminal (logged in as root, of course), type:

modprobe snd-via82xx
modprobe snd-pcm-oss
modprobe snd-mixer-oss
modprobe snd-seq-oss

The first line should do the trick, but lets cover all of the bases to be sure.

Could the fix really be that simple?
 
Old 04-11-2005, 03:46 PM   #21
xzallion
LQ Newbie
 
Registered: Apr 2005
Posts: 17

Original Poster
Rep: Reputation: 0
mjmwired: following what you said heres what I got

[kenneth@localhost ~]$ ls -la /etc/modprobe.conf
-rw-r--r-- 1 root root 368 Apr 9 14:05 /etc/modprobe.conf
[kenneth@localhost ~]$ cat /etc/modprobe.conf
alias eth0 b44
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
[kenneth@localhost ~]$

I dont understand all that, but I figure it could help

WhatsHisName: I will do as you said here in a moment, first I have some homework that must be done first. Im sorry for the lack of resoponses the last few days, weekend and school happened.
 
Old 04-11-2005, 04:40 PM   #22
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
The work system I mentioned contains an “ADI AD1888 SoundMAX 5.1 Audio” chip and also runs on the via82xx module. The relevant parts of its modprobe.conf are:
Code:
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };  /sbin/modprobe -r --ignore-remove snd-via82xx
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
After you run the modprobe commands:
Code:
modprobe snd-via82xx;modprobe snd-pcm-oss;modprobe snd-mixer-oss;modprobe snd-seq-oss
your’s will probably look similar.
 
Old 04-11-2005, 05:02 PM   #23
xzallion
LQ Newbie
 
Registered: Apr 2005
Posts: 17

Original Poster
Rep: Reputation: 0
[root@localhost ~]# ls -la /etc/modprobe.conf
-rw-r--r-- 1 root root 368 Apr 9 14:05 /etc/modprobe.conf
[root@localhost ~]# cat /etc/modprobe.conf
alias eth0 b44
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
[root@localhost ~]# modprobe snd-via82xx
[root@localhost ~]# modprobe snd-pcm-oss
[root@localhost ~]# modprobe snd-mixer-oss
[root@localhost ~]# modprobe snd-seq-oss
[root@localhost ~]# ls -la /etc/modprobe.conf
-rw-r--r-- 1 root root 368 Apr 9 14:05 /etc/modprobe.conf
[root@localhost ~]# cat /etc/modprobe.conf
alias eth0 b44
alias snd-card-0 snd-intel8x0
options snd-card-0 index=0
install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
[root@localhost ~]#


Thats what I did, and I have verified that nothing is muted and that everything is turned all the way up
Unfortunatly sound does not work on the front or back ports.

WhatsHisName: Do I need to install the drivers from that page or just type what you said to type into the terminal? cause I only typed that into the terminal.
 
Old 04-11-2005, 06:09 PM   #24
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
Let’s try something a little more aggressive and see if FC3 can figure it out on its own.

Modify /etc/modprobe.conf using a text editor (see Accessories menu) to look like this:
Code:
alias eth0 b44
#alias snd-card-0 snd-intel8x0
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
#install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
#remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
The only changes were the addition of 3 “#” comment marks and the addition of:
alias snd-card-0 snd-via82xx

Now save modprobe.conf and reboot.
 
Old 04-11-2005, 09:49 PM   #25
xzallion
LQ Newbie
 
Registered: Apr 2005
Posts: 17

Original Poster
Rep: Reputation: 0
I copied all that into the modprobe.conf, overwriting everything, and saved and rebooted.
Tested with both front and back ports, nothing.
double checked volume levels, unmuted and maxed them out, and still nothing on both ports.
I got a error on shutdown, may have been a fluke. If it happens again i will post what it says.
I really thought that would work
 
Old 04-12-2005, 07:07 PM   #26
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
Before I recommend installing a supported sound card (which is not a bad idea anyway), try one more thing. This is what you might call getting-back-to-basics.

Logged in as the root user, run alsamixer from the terminal, which will give you a pseudo-graphic representation of the volume settings. You will be able to move around the volume adjustments using the left/right keys, adjust the volumes using the up/down keys and toggle the muting (i.e., [off] in the upper left area means the selected channel is muted) using the “m” key.

What card and chip does it show in the upper left corner of the alsamixer terminal window?

Are the Master or PCM [off] / muted? If they are [off], then use the “m” key to turn them on, open a second terminal and enter the command “alsactl store”, which stores the current settings.

Let me know what you see.
 
Old 04-12-2005, 10:12 PM   #27
xzallion
LQ Newbie
 
Registered: Apr 2005
Posts: 17

Original Poster
Rep: Reputation: 0
card: Intel 82801DB-ICH4
chip: Analog Devices AD1981B
is what it shows in the alsamixer panel

Nothing is muted and everything is already turned up.
I guess sound won't work on this without a sondcard installed....grr...
 
Old 04-12-2005, 11:05 PM   #28
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
Now we know for sure that we are knocking on the correct door.

The problem is that since FC3 is not autodetecting the sound chip, none of the ususal autoconfiguration is taking place. So, try adding an extra line from my work system’s modprob.conf to your /etc/modprobe.conf and then reboot.
Code:
alias eth0 b44
#alias snd-card-0 snd-intel8x0
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };  /sbin/modprobe -r --ignore-remove snd-via82xx
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
#install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
#remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
The third line (i.e., remove snd-via82xx...) is the extra line. Just copy it from this web page and stick it into your modprobe.conf. Except for the sound module, it is the same line as was originally directed at snd-intel8x0.

And if that doesn’t help, then try adding the “install snd-intel8x0...” line before the “remove snd-via82xx...” line, change the two intel8x0's to via82xx and reboot.

It would look like this:
Code:
alias eth0 b44
#alias snd-card-0 snd-intel8x0
install snd-snd-via82xx /sbin/modprobe --ignore-install snd-snd-via82xx && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };  /sbin/modprobe -r --ignore-remove snd-via82xx
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
#install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
#remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
 
Old 04-13-2005, 06:48 PM   #29
xzallion
LQ Newbie
 
Registered: Apr 2005
Posts: 17

Original Poster
Rep: Reputation: 0
Modprobe.conf

alias eth0 b44
#alias snd-card-0 snd-intel8x0
install snd-snd-via82xx /sbin/modprobe --ignore-install snd-snd-via82xx && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx
alias snd-card-0 snd-via82xx
options snd-card-0 index=0
#install snd-intel8x0 /sbin/modprobe --ignore-install snd-intel8x0 && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
#remove snd-intel8x0 { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-intel8x0
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd

still no sound
I tested front and back ports for both, and made sure that sound was on and turned ALL the way up. still nothing.
 
Old 04-14-2005, 06:52 PM   #30
WhatsHisName
Senior Member
 
Registered: Oct 2003
Location: /earth/usa/nj (UTC-5)
Distribution: RHL9;F1-10; CentOS4-5; DebianSarge-Squeeze
Posts: 1,151

Rep: Reputation: 46
And now for something completely different...

Well, it’s time to look at supported sound cards. Given how much better they sound than the onboard versions, you will come out ahead anyway. Also, it’s nice to have an S/PDIF output to drive a home theater system.

An easy way to pick one out is to go to the ALSA soundcard page and see what is supported. But be sure to read the notes associated with the actual sound module before deciding on a card and to search this forum for people having trouble with the card. Like most hardware, the newer sound cards typically have the worst driver support, but it will get better for any hardware as time goes by (i.e., think 3-6 months).

If I were buying one today, I would probably get one from the 7.1 Sound Blaster Audigy2 ZS series, which seem to have decent ALSA support. The Sound Blaster Audigy2 ZS Value (ALSA module snd-emu10k1) goes for about US$60.

Another cheaper 7.1 card is the Sound Blaster Live 24bit (ALSA module snd_ca0106), which goes for US$30. Although you would probably need to install the current driver from the ALSA site, someone has already worked out the details for you in another thread (http://www.linuxquestions.org/questi...hreadid=307451).

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound card detected (dell integrated audio, RH9) otto85b Linux - Hardware 15 07-15-2010 05:21 PM
SoundMAX Integrated Digital Audio card - problem with listening to music igor@44 Linux - Software 3 09-09-2005 03:38 AM
No sound on Slackware 10 with SoundMAX integrated controller. binary5 Linux - Hardware 3 07-17-2004 12:18 AM
No sound (SoundMax Integrated Digital Audio) giill Linux - Hardware 5 11-22-2003 11:04 AM
RedHat 7.3 and SoundMAX integrated sound linuxchick Linux - Newbie 2 09-24-2002 05:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 06:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration