-   Fedora (
-   -   sony vaio grx560 modem hsf drivers compile but don't work (

mitchell1000 02-02-2004 12:42 AM

sony vaio grx560 modem hsf drivers compile but don't work
Hi i have been trying to get the winmodem in my sony vaio laptop working with any of the drivers available.
the modem is a Intel 82801CA/CAM AC'97 Modem Controller

I scoured the web and tried multiple attempts.

i compiled the slmdm-2.7.10. , the slmdm-2.7.14 and the slmodem-2.9.4 drivers. I compiled them succesfully in each case and failed only when it said that the /dev/modem or /dev/ttys* device where s* is for each corresponding driver different. it always said cant find the device. even though there clearly was a device if you do ls /dev/ttyS[whatever].

I tried a variety of approaches. I tried using the hsflinmodem drivers from conextant. i succeeded in compiling them by following someones idea to comment out the part of the code causing failure in modules/serial_core.c. But now i still cant get minicom to do anything. It starts, and i have ttySHSF0 as the serial port and still i dont get the OK signal from the modem.

any ideas on what i can do


beyond_2000 02-02-2004 12:16 PM

maybe the driver itself does not support your machine. mine is sony gr390 ,which is an very old machine. but i don't think i have chance to use the modem.
your machine is powerful, i strongly recommend you to install SuSE, which make a lot of patch for sonypi.

All times are GMT -5. The time now is 04:53 AM.