-   Fedora (
-   -   Solved! FATAL: Error inserting acpi_cpufreq (.../acpi-cpufreq): No Such Device (

PTrenholme 11-06-2006 02:30 PM

Solved! FATAL: Error inserting acpi_cpufreq (.../acpi-cpufreq): No Such Device
After upgrading my laptop from FC5 to FC6, I was getting the above message during the boot sequence.

When I looked at the Red Hat bugzilla for this problem, I saw that someone had solved it by installing the correct kernel version.

When I looked at the kernel I was running, I discovered the the upgrade had installed the i586 kernel instead of the i686 one. When I switched to the i686 version, the problem went away. (My Gateway laptop uses an AMD Sempron 3300+.)

Note: Switching the kernel was "automated" for me by the smart update manager, available from the extras repository.
(If you install it, get the Fedora configuration package too. And be sure to update the "channels.")

reddazz 11-07-2006 03:58 AM

I installed the right kernel on the same day I did my installation, but my laptop still displays that error on boot up. I will wait for a kernel upgrade and see if that will fix it for me.

Linux31 11-07-2006 04:29 AM

Which raises the question, during the initial installation which version is it installing? I have an Athlon 3800+ (dual core). Now I'm wondering if my problems stem from the wrong version.

reddazz 11-07-2006 04:43 AM

During installation, an i586 kernel was installed on my system instead of an i686.

PTrenholme 11-07-2006 10:05 AM

Installing the correct kernel also fixed a DRI problem I'd noticed
I hadn't done anything (since I hardly ever use it) even though 3-d rendering was not working properly on my laptop. I just checked fgl_glxgears (which was giving me a "XFree86-DRI missing" message), and it is now working correctly. (Of course, I did have to install the correct ATI driver from the Livna repository since the kernel version had changed.)

rowancompsciguy 11-28-2006 06:21 PM

Good find this saved me a ton of trouble!! Thanks!!

rapix 01-13-2007 07:26 AM

I was getting that error message too..
after reading this topic i installed i686 kernel instead of i586
but i am still getting same message.
my laptop(intel P4 3.2)

All times are GMT -5. The time now is 08:55 PM.