-   Fedora (
-   -   snd-via82xx no sound but works in other distros (

WireLine 03-04-2005 10:29 AM

snd-via82xx no sound but works in other distros
Details first:
Motherboard: DFI K8M800-MLVF (mini-atx with on board sound, video, lan)
Hauppauge WinTV Go PCI card
Fedora Core 3

I am trying to get the sound card to work. It works fine in debian, knoppix, suse 9.1 but I don't like those distros as much as I like Fedoa :)

I have tried the most obvious things like making sure that the volume was not muted and that it was turned up. Also I have ran the sound card detection tool it comes up the the snd-via82xx module. I have updated my alsa drivers to the latest from (I am using apt). I don't see any error messages from dmesg or anything like that.

What now? How do I continue to troubleshoot this? Or better yet has somebody gotten this to work?

Sakur 03-05-2005 07:19 PM

"alsamixer" to open channels , it is defaully closed in FC3

WireLine 03-05-2005 08:17 PM

I should have been more specific, I did use alsamixer to check for muted channels something is wrong with the driver in general.

I also used Fedora volume control panel and it did not help either.

Any ideas whats next? If I had an open PCI slot I would slip in a different sound card but they are all full at the moment.

purwant 03-05-2005 08:23 PM

hi go to the termminal and type kmix then increase te levels of pcm and headphone that's it
alternatively try alsamix if you have installed it

also if this work tell me how to post a question.


Sakur 03-05-2005 08:29 PM

seems really strange, i also use snd-via82xxx,which works fine in my FC3,could u give me the some useful info to let me what condition u r in , like the result of " dmesg " 'lspci" " lsmod",

WireLine 03-05-2005 08:32 PM

no kmix, using gnome.

To post a quest go to the correct forum and click new topic at the top.

Every single option in alsamix is unmuted and maxed out. I have also tried many diffrent combos to get it to work.

WireLine 03-06-2005 10:37 AM

Well I got it working kind of now.

Here is what I did. I grabbed the Alsa Kernel module and the Alsa-driver rpm. Installed those. I turned of my sound card in the bios somewhere in there let Fedora boot up and removed the sound card config. This part was not nessarry but I was furstrated. Then I rebooted and re-enabled it let kudzu dectect and install it. Used alsa mixer which now had about a hundred diffrent volume levels and tweaked them tell I head sound.

Now I just have to figure out why my line in is all distorted and why it does not save my volume levels. Thanks for all your help.

wfcloherty 09-08-2005 09:49 PM

reply: snd-via82xx no sound but works in other distros
I had the same problem with the Ubuntu 5.04 distro on the same hardware.

The fix for Ubuntu was to go into ALSAMIXER and turn off (mute) the IEC958 Capture Monitor [off] channel. I also had to restore the sound system back to the original setup as installed, I had really messed it up while trying to get it to work.


whencat 09-10-2005 03:36 AM

To save the mixer settings........
1. Set the desired volume in the desired channels in alsamixer

2. type
#alsactl store
[or give the full path to alsactl]

This will store the current settings in /etc/asound.state.
You can also edit the above file directly if you are comfortable with it.

All times are GMT -5. The time now is 07:29 AM.