-   Fedora (
-   -   Slack/Fedora dual-boot using LVM (

Phaete 04-10-2005 09:36 PM

Slack/Fedora dual-boot using LVM
After reading a How-To on LVM, I suspect I made a big mistake when adding a new HDD and Fedora install to a working Slack 10 system.

I booted from the Fedora bootable CD burned from ISO and the install ran fine. The existing system is a Slack install to a smaller 4GB HDD (hda). I installed the Fedora Core 3 onto a clean 10GB drive (hdb) and decided, rather than screw something up when asked to install GRUB, I said no assuming I would simply add boot instructions to my existing /etc/lilo.conf after install.

So, Fedora finished and I ran #fdisk /dev/hdb to see how files were laid down:

Disk /dev/hdb: 10.2 GB, 10248118272 bytes
255 heads, 63 sectors/track, 1245 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 1245 9896040 8e Linux LVM

It seems the default Fedora install uses LVM. I can't seem to mount this filesystem (if there is such a mount of it), so obviously can't modify lilo for a second OS boot.

Is this possible or must I reinstall Fedora selecting either a GRUB installer or more native filesystem than using a Logical Volume Manager? I would actually like to keep LVM intact if it isn't too much for a newbie

Thx in advance!

Phaete 04-11-2005 07:20 AM

Setup information
Contents of fstab (after I added the /fedora mount point to /hdb1 and guessed at file type of reiser since both partitions display as type 83 = Linux in fdisk ... this is probably incorrect?!):

root@DaBox:/fedora# more /etc/fstab
/dev/hda1 swap swap defaults 0 0
/dev/hda2 / reiserfs defaults 1 1
/dev/hdb1 /fedora reiserfs defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
/dev/fd0 /mnt/floppy auto noauto,owner 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
proc /proc proc defaults 0 0

... and I created a symlink to the fedora kernel called /fedora/vmlinuz, as below:

root@DaBox:/fedora# ls -p initrd-2.6.9-1.667.img vmlinuz-2.6.9-1.667
config-2.6.9-1.667 lost+found/
grub/ vmlinuz@

... finally, I manually added the boot setup in /etc/lilo.conf as follows:

root@DaBox:/fedora# more /etc/lilo.conf
# LILO configuration file
# generated by 'liloconfig'
# Start LILO global section
boot = /dev/hda2
message = /boot/boot_message.txt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
# VESA framebuffer console @ 1024x768x256
vga = 773
# End LILO global section
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda2
label = Slackware 10

image = /fedora/vmlinuz
root = /dev/hdb1
label = Fedora Core-3

# Linux bootable partition config ends

I only get one OS option upon boot, however.

snecklifter 04-13-2005 01:50 PM

You'll need to check Reiserfs support for your kernel and lilo. I dont think lilo supports reiser on one of the kernels (2.4 or 2.6, cant remember) but this will be the source of your problems.

Phaete 04-14-2005 04:13 PM

I believe the problem to be in my lilo.conf definition.

Based on feedback I get from successful Slack boot, /dev/hdb1 is ext3, not reiserfs, so I changed the lilo.conf to reflect this.

Also, I was missing a line related to initrd, so added that as well. I'm offsite, so don't have the exact syntax, but I have modified fstab to:

/dev/hdb1 /mnt/fc3 ext3 defaults 0 0

Selecting the Fedora boot now properly attempts the load of the fc3 kernel, but I still get kernel panic after the kernel discovers a mounted 'volume' called "VolGroup00". I have gotten further with the initrd instruction, but it still bails with something about not being able to mount a file system. I will post the specifics, later, but I suspect it has something to do with mounting the filesystems WITHIN the LVM volume group.

All times are GMT -5. The time now is 01:30 PM.