LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 01-20-2007, 03:26 PM   #1
CaptainInsane
Member
 
Registered: Nov 2003
Location: Peoria
Distribution: Fedora 8
Posts: 92

Rep: Reputation: 15
Question service start/stop command stalls.....


Been having a strange issue with my server since FC6 install.
Currently at kernel version 2.6.19-1.2895.fc6 #1 SMP

Have the box booting up in runlevel 3. When I enter the command
service vsftpd start (or stop), the machine will stall out, for 2-10
minutes before the command finishes and the prompt shows back up.

During this time, something is eating up huge amounts of ram, and sometimes
even thrashing on the swap file. Machine is a P4 2400 with 2 gig ram.

Same thing if I use service iptables start/stop, so it is not related to
the vsftpd config, which does work fine once it finally loads.

If I have the service starting automatically at boot time, it loads up
fine with no delay.

Everything else seems to be running fine on it. Only clue from top is
there seems to be a unicode_start process bouncing around in the list while
this is happening.
Sometimes multiple copies of it.

Never had these issues with RH9 or FC4 on the same machine.

Anybody got any ideas ?

Thanks in advance.
 
Old 01-20-2007, 03:44 PM   #2
Brian1
LQ Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 64
Have you booted with a non smp kernel?
Could be an issue with that precompiled kernel?
Has older versions of the kernel worked fine using the service command?

Brian
 
Old 01-20-2007, 04:03 PM   #3
CaptainInsane
Member
 
Registered: Nov 2003
Location: Peoria
Distribution: Fedora 8
Posts: 92

Original Poster
Rep: Reputation: 15
With FC6, choosing smp or non-smp doesnt seem to be an option. Believe it
just provides one, that detects if your processor is smp or not.

Unknown if it is issue with the precompiled kernel.

Did not have this issue with FC4 kernels that were current up to a month ago, but
those are now gone off this machine as I did a fresh install of FC6.

Note, it is using the i686 kernel, not i586.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to register auto start/stop service script with chkconfig travellers Linux - Software 8 06-15-2009 11:02 AM
auditd outputting errors at service start & stop cdhgee Fedora 8 08-08-2005 01:22 PM
start/stop service on the fly zchoyt Linux - Software 3 04-14-2005 03:30 AM
remotely start/stop service on WinNT PC from Linux cuzality Linux - Software 0 09-01-2004 01:48 PM
Is it possible to start stop and restart a linux service from a webpage? psychodreams Linux - Newbie 3 04-27-2004 01:24 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 12:22 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration