LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Fedora (https://www.linuxquestions.org/questions/fedora-35/)
-   -   sendmail won't do anything (https://www.linuxquestions.org/questions/fedora-35/sendmail-wont-do-anything-310737/)

ichi 04-07-2005 10:27 AM

how to set up a Fedora 3 mail server
 
I am a newbie to Linux, and even more to Fedora 3.

I have ssh access to a FC3 server upon which I'm trying to set up a mail server with sendmail.

On my laptop which I work from I can do sendmail -v user@localhost < hello.txt' and a message with the contents of 'hello.txt' magically arrives in user's inbox (when logged in as that user and do 'mail' in bash).

But on this server...it simply refuses to work. when I do the same operation on the server, I get this:

Code:

user@localhost... Connecting to [127.0.0.1] via relay...
localhost ESMTP Sendmail 8.13.1/8.13.3; Thu, 7 Apr 2005 08:22:50 -0700
>>> EHLO c-24-21-217-195.client.comcast.net
localhost Hello localhost.localdomain [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-EXPN
250-VERB
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-AUTH DIGEST-MD5 CRAM-MD5
250-DELIVERBY
250 HELP
>>> VERB
250 2.0.0 Verbose mode
>>> MAIL From:<user@localhost> SIZE=6 AUTH=ichi@c-24-21-217-195.client.comcast.net
250 2.1.0 <user@localhost>... Sender ok
>>> RCPT To:<user@localhost>
>>> DATA
050 <user@localhost>... WARNING: cannot open alias database /etc/mail/aliases; reading text version
250 2.1.5 <user@localhost>... Recipient ok (will queue)
354 Enter mail, end with "." on a line by itself
>>> .
050 <user@localhost>... queued
250 2.0.0 j37FMoRm012174 Message accepted for delivery
user@localhost... Sent (j37FMoRm012174 Message accepted for delivery)
Closing connection to [127.0.0.1]
>>> QUIT
221 2.0.0 localhost closing connection

(I've replaced the server's name with localhost host and the username with user; I'm trying to send the mail to myself).

Which appears to be perfectly OK, apart from the alias warning...I've no idea what that's about. But when I check user's mail...it doesn't exist.

I am totally unexperienced with these matters, so I have no idea what might be wrong and so have done nothing to fix it.

This doesn't work for any user, including root.

If I get sendmail to work, will that only work for sending mail? What is a good program to use for recieving mail?

VERY many thanks for any help...this is really annoying me :mad: .

EDIT: Newbie me didn't set up DNS, that's why it didn't work. Sorry, Mods feel free to delete this thread :newbie:


All times are GMT -5. The time now is 07:35 PM.