-   Fedora (
-   -   SElinux Disaster / Can't Login / X11 Blocks (

tarek_taha 06-08-2006 03:14 AM

SElinux Disaster / Can't Login / X11 Blocks
HELP am stuck. Well all i did was updating the SElinux new policies through yumex i had no idea that this is gonna happen, everything was running smooth. Now i can't login to X11 , it gives error messeges during booting " can not open shared object", i know this is about the booleans in the SElinux thing but I CANT LOGIN, not even with a text console. I CANT ACCESS ANYTHING , I would apprciate ANY ideas. by the way i tried to boot into the text runleve by modifying the kernel arguments but still can't login to console, not even as root. This is frustrating .........

tarek_taha 06-08-2006 03:21 AM

by the way, i tired to set SELinux off through the kernel command line and still the same . Any other ideaS?

tarek_taha 06-08-2006 04:58 AM

I've tried everything i know until now and i still am getting no where, even when i switch to text mode i can't login, it keeps on asking me about the user name, didn't even get to the stage where i can enter my password. Any ideas ? I think i will endup reinstalling the Fedora system, even though am not sure that will help ...

Crito 06-08-2006 08:16 AM

You wanted security? You got security! Your system is now so secure it's completely useless. You should bury it in 6 feet of concrete too. :o LOL

Sorry I don't have an answer for you, but despite my dislike for the NSA loving Clintonistas with their Clipper chips and selinux kernels, it might not be selinux's fault this time. Just seems there would be a whole heck of a lot more people here with same prob if a simple yum update of your policies caused it.

tarek_taha 06-08-2006 09:19 AM

Am back on my machine, i fixed it without fixing it :) i had to reinstall Fedora and upgrade the system, fortunatly it only changed few packages and i kept my data, so i didn't do much other than updating the kernel. And ya it was about that fcking pam security package with the Selinux policies i updated, i dunno what happened i have no answer to that and as much as i hate fixing things this way "re-installing" but i don't have time to search and wait for help, lot of work i have to do :)

Thanks anyways

Crito 06-08-2006 09:29 AM

Always good idea to have /home on a separate partition just for these occasions. So you can blow away the whole system and still keep your data, that is. ;)

All times are GMT -5. The time now is 03:33 PM.