-   Fedora (
-   -   Segmentation Fault (What is that?) (

jlacroix 11-13-2003 10:32 AM

Segmentation Fault (What is that?)
Quite a few things are giving me a "segmentation fault" error message. What does that mean?

Most notably, when I am in the console and I type "xawtv" to load the TV player software that was bundled with Fedora, it shows it for a brief second then returns with the message "segmentation fault".

How do I fix that?

mishmash 11-13-2003 11:04 AM


What it means is that the application you are trying to use has performed an illegal action (generally in regards to memory). It is kind of the same as a Windows' GPF, although in Windows (especially for 9x/Me versions...) it is because of a not so good kernel.

So, there is not much you can do exept trying to get a patch for that application. Please note that maybe it is caused by a RPM package used by some of your applications.

mishmash 11-13-2003 09:45 PM


I tried the application you just mentioned and I got the same error...

This is xawtv-3.88, running on Linux/i686 (2.4.22-1.2115.nptl)
Warning: Cannot convert string "-*-ledfixed-medium-r-*--39-*-*-*-c-*-*-*" to type FontStruct
Segmentation fault


As you can see the application could not convert a particular string and stopped!

Not much you can do except report it. Maybe someone else found what is the cause for this segmentation fault... It could be related to a media rpm package of some sort or could be the application itself.

Starchild 11-14-2003 01:59 PM

You might have success if you recompile it yourself.
I have downloaded at least one binary that seg-faulted on my system, but the program worked fine when I compiled it myself.

In this case, a bug-report should definitely be submitted, as you really should be able to run the binaries bundled with the system.

wiraone 11-14-2003 02:28 PM

Answered in this post:

Did the test myself, xawtv w/o argument will seg fault, but with -device /dev/video0 option works.

mishmash 11-14-2003 09:14 PM


c0uchm0nster 11-17-2003 08:32 PM

I'm also running Fedora 1. xawtv worked fine (no arguments) when my machine was running rh8, now it's crashing. I'm not having any luck with either the -noxv tag (no window ever opens), nor with the device tag (still get a segmentation fault)... I'm wondering if anyone else is also experiencing trouble with this, or do the above options fix most peoples problems?

All times are GMT -5. The time now is 09:59 PM.