-   Fedora (
-   -   screen looks like static on gui bootup (

Qvintvs 11-08-2008 10:24 AM

screen looks like static on gui bootup
I just installed Fedora 9 on my internal drive (after I kept getting segfaults when trying to run Sabayon, but that's another story...).

The install seemed to go fine. When I tried to boot though, I get some messages saying "ACPI: Error attaching device data" (4 or 5 of those), and some other text (like "Press I for interactive bootup", things like that). Then the screen gets messed up and starts looking like static. If I press ctrl+alt+f1, I get to the screen that listed the ACPI errors, but if i got back to the "gui" with ctrl+alt+f8, I get the static again.

btw, I have an ATI card (hd 4870x2), if it matters.

Anyone know why this is happening and/or how to fix it?

Any and all help is appreciated!

amani 11-08-2008 10:29 AM

Go to your bios.

Try modifying settings relating to video bios

Also go to for reviews on your card

Optional: post details of lspci -vvv

Qvintvs 11-08-2008 10:57 AM

I tried playing around with some of the bios settings but they didn't help. Is there something specific I should be looking for?

Also, where would I run lspci -vvv? It doesn't work in the Windows command line or in grub, and I don't have access to a fedora command line.

theNbomr 11-08-2008 12:40 PM

You should be able to login to a bash shell by pressing Ctrl_Alt-F2 - Ctrl_Alt-F6 at any time. These are the first 6 (including the default Ctrl_Alt-F1) virtual terminals. From the bash commandline, you can run any non-X programs, including lspci. Other tools that may be of diagnostic value would be dmesg, cat /var/log/messages, cat /var/log/Xorg.0.log. Better still, use another working computer to ssh log in to your F9 computer, so you can use copy/paste to report interesting results back here.
--- rod.

Qvintvs 11-08-2008 02:42 PM

Going to any of the virtual terminals just leads me back to the screen that gave me the ACPI errors (and other info). I can type, but pressing enter just goes to a new line, and doesnt execute the command. I also dont think I'm actually at a virtual terminal, because pressing ctrl+alt+f(1-6) doesn't do anything. If I type the letter a and just leave it there, it'll be in all the "other" 6 screens too.

theNbomr 11-09-2008 09:59 AM

Okay, it seems that you are not getting a complete enough boot that the virtual terminals will work. Perhaps you can try booting to runlevel 3 to see if the graphics is the real foul-up, or if there is something else happening first that just make the graphics look like the faulty element. If you get a clean boot, then you can try starting X from there, with startx.
--- rod.

All times are GMT -5. The time now is 03:45 PM.